summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 08:40:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-02 09:50:34 +0200
commit0949860122b32d0dd2bae6f511e875377036f7c6 (patch)
treec3d72e69f9e9fd6020b3f44366a7ab8cbc55def2 /dev-python/botocore
parentdev-python/identify: Bump to 2.3.0 (diff)
downloadgentoo-0949860122b32d0dd2bae6f511e875377036f7c6.tar.gz
gentoo-0949860122b32d0dd2bae6f511e875377036f7c6.tar.bz2
gentoo-0949860122b32d0dd2bae6f511e875377036f7c6.zip
dev-python/botocore: Bump to 1.21.53
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.53.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9891366fd1d3..3867a3a18b63 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,3 +12,4 @@ DIST botocore-1.21.49.tar.gz 8202118 BLAKE2B cdda23ddbd1d9540c8dc1e53763bfccf998
DIST botocore-1.21.50.tar.gz 8204209 BLAKE2B a2db3a93696d6be68268265a7dbd1809edcaf9a3039974d55d718a86a3f9c8a08342f54ec9a491cdb0d32b6bb5505bc17e21d43fa8be2a93b34cc8305fb06b55 SHA512 b487a0463159d6e9109f8d195a567c0c086f705406b52554f2f18ccd57aff6e116e9176716a79f5d24066a43a8193ec088fdd4671df69d6c23102537b59c4f7d
DIST botocore-1.21.51.tar.gz 8204164 BLAKE2B cf9a74b509ee721d19dc3c2f3e6c1ed5f571ea35ab813402d13d285c5f465f8146b1fe3ca99b863e4eb48574034ccadca6dfd0cc118f267ea917d4822f1bfa73 SHA512 4835bfcceb14a46315afdd74ee8015d51c951c4dd8e8b49fbbd9c02bbfd2958925b52661a65a9a26be6c386e2d251bea4322a8f9c3749d4815f2efdb97e403f8
DIST botocore-1.21.52.tar.gz 8219147 BLAKE2B 2f60387b57cae96f288d08f71a68c6135c3e13008a31f4e9fd7dc19b9a98a90b20de92d7b3aa2e0a793524cf3944b5a707202e201214eb3fd84a8da47486473e SHA512 9b773e6852ab2b5f7f96383b6dc2d0d7d85d45d2124cc896e216cea576f82be8a642bdc8664b3478901dc154898211b9a3ef5cc0501cdf0f9cc75a6eb170cba7
+DIST botocore-1.21.53.tar.gz 8221904 BLAKE2B 79a87c9678fad9f3b4503740d9857579850eb2e6cf8371e233b9957b031e79aa04f28ce35b96826bfa4ff08c84a7ec646c8cd4302e5eb785530e8f3e2bf9b2f2 SHA512 0a3704d68a09a1afe53d4321d327036f4581d8c6942bc02f594c26d24fa2a60cfbbfab595cc3c4a4e9d3439790835739f7be8c3b572536feb655646c7800cf61
diff --git a/dev-python/botocore/botocore-1.21.53.ebuild b/dev-python/botocore/botocore-1.21.53.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.53.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}