summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-08-11 23:03:43 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-08-11 23:08:56 +0200
commit0b7506a53f58a252d373a40a34f10c7da0c8119a (patch)
tree277a702463950956373bb5b4ad54eb446ca21622 /dev-python/botocore
parentmedia-gfx/imagemagick: bump to v7.0.10-27 (diff)
downloadgentoo-0b7506a53f58a252d373a40a34f10c7da0c8119a.tar.gz
gentoo-0b7506a53f58a252d373a40a34f10c7da0c8119a.tar.bz2
gentoo-0b7506a53f58a252d373a40a34f10c7da0c8119a.zip
dev-python/botocore: version bump 1.17.40
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.40.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c7bd87499cd0..cfde78656be4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.17.27.tar.gz 6637309 BLAKE2B 8c3d8d27b13c55c11b4934e0af35bb0a01c
DIST botocore-1.17.28.tar.gz 6647521 BLAKE2B e9da32dd9202bc1ad621003bb6196873380f0015553cd906465382d21d30b7b83313e6be4e8d3d8abf4f6472180319a98677a3a245ad69bf6bde5d8e08264577 SHA512 5388518dc0bf598a3ea848df38454c49692abaf7ebe23e0ab0b1416139a4363b712260591e644c415ea3ea4cbac105011fef4d565b95fd3045fe6e4d3c7318a8
DIST botocore-1.17.31.tar.gz 6665851 BLAKE2B dbc89d1216f9fda89c6185baccfdf2878c265d8761e4ad1349a45d334f9a4d5b79ad1ce06a19a7a706b75be1a6d7f2a7bf5bc33d8ffbe7ad8a016472edf0432f SHA512 ab1921fae887846d1c224d624e8d5dd888ab9c0c90a415ac97e5ad2f7563131b199e8870553e7f3dd6f5ff4c7901aa04bfa99160aca4e9da8ef3096cfd922ec9
DIST botocore-1.17.34.tar.gz 6683317 BLAKE2B a3229c09f7c21a95140e22d9902161b705bccf1a9559b6ba2bf45e5e79f2f2af7e86fcbae3654405faf73e4eb6a8f86a88c407aafb411c646d54aed72af8b162 SHA512 f5fe7803c4e083de7515f7bd58f84709ebaa8007d707273c6bf9fac1391b7d5ab7e8771725db59b9b6b5dd60e71f34140ae5435dec18ffc364c1779172de9bab
+DIST botocore-1.17.40.tar.gz 6693291 BLAKE2B 233042aa9641d874b0d3d5907d8d4afabbd3ea72756f2ba8ca219b3f5f1c246465cba6809e23a670db2a9d75e2c8f1e04c3c12cafb73952530fbf847ad7b42d6 SHA512 b9d0e180d5e8e659d13676110856dc01943c4057c23437a41edf40366e76f2c92eb119c004fde45ee53e2b82b1716e0334a18a6b5ea4e4de30f02cfd5b711b0a
diff --git a/dev-python/botocore/botocore-1.17.40.ebuild b/dev-python/botocore/botocore-1.17.40.ebuild
new file mode 100644
index 000000000000..6b14dce9712f
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.40.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}