summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-14 07:47:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-14 09:50:53 +0200
commit22e3a2460cde3150b48831bc3ddadda2b9763c15 (patch)
tree133340b55e3c89e8bb3e6e5d2eb1d61d92897d1c /dev-python/botocore
parentdev-ml/opam: apply same dose patch as for other opam* in 2.1.0 (diff)
downloadgentoo-22e3a2460cde3150b48831bc3ddadda2b9763c15.tar.gz
gentoo-22e3a2460cde3150b48831bc3ddadda2b9763c15.tar.bz2
gentoo-22e3a2460cde3150b48831bc3ddadda2b9763c15.zip
dev-python/botocore: Bump to 1.21.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.61.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d80b06fb2420..026963cc55ad 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.21.40.tar.gz 8149052 BLAKE2B 0554e2b9caa08b7518f1b51b5a980d98926
DIST botocore-1.21.47.tar.gz 8183951 BLAKE2B 930fdccd5d45fb1fb88fec2370e65bff5eb7241ea3a666f1f0bfeb11ee3e1e5bb715d658ac1f340c0565f16bbba48fa57c7460aef0e0595486303f62f79df244 SHA512 705fa363bdd4663f774e349e448666d7bfd47c77b57689d6cc12039419c8a4f820d7edd01de9689cd56fee3d59138ea9bd803b4402c8b5fac95cd2de76fb1558
DIST botocore-1.21.53.tar.gz 8221904 BLAKE2B 79a87c9678fad9f3b4503740d9857579850eb2e6cf8371e233b9957b031e79aa04f28ce35b96826bfa4ff08c84a7ec646c8cd4302e5eb785530e8f3e2bf9b2f2 SHA512 0a3704d68a09a1afe53d4321d327036f4581d8c6942bc02f594c26d24fa2a60cfbbfab595cc3c4a4e9d3439790835739f7be8c3b572536feb655646c7800cf61
DIST botocore-1.21.60.tar.gz 8253381 BLAKE2B f035a335f8d72c182f6fbd3f2216608bd5683e70ae11fd8646ff81416262ec802aac5b084f0cf96d23fd6767bbe678e35b24377d82186440b3ee55c977b42643 SHA512 7e801f67c670a85ebd0641fe8a51890dcea1a3a6f2253cca1213ee96a20497c1196c16b2576bcd2dc796b501117d609240c59b1077bbdc0f3021cf6659289e21
+DIST botocore-1.21.61.tar.gz 8255275 BLAKE2B 53f5e6c3af455bd92f59152d28ed7a598c1743c9cc648bf28922ce2833f53f7fa01de052109225117cc52126593bf51ca56765d35d1e25ced2a4a2a2f88326c5 SHA512 8cd110f78acb1dfc29f9eda5bcecdecba07e2846faab063c8d86294ae81935783e62c66f7588d505a2f6ca69445eaa80835011ac7b19e975e8dce9f65b28b429
diff --git a/dev-python/botocore/botocore-1.21.61.ebuild b/dev-python/botocore/botocore-1.21.61.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.61.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}