summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 00:16:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 00:36:57 +0200
commit4cb47433ada57da30da5d82c3891a7965bd3323a (patch)
tree15a972afb68e7955d86eb030ff0ac36c1010674d /dev-python/botocore
parentdev-python/bitarray: Bump to 2.2.2 (diff)
downloadgentoo-4cb47433ada57da30da5d82c3891a7965bd3323a.tar.gz
gentoo-4cb47433ada57da30da5d82c3891a7965bd3323a.tar.bz2
gentoo-4cb47433ada57da30da5d82c3891a7965bd3323a.zip
dev-python/botocore: Bump to 1.21.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e84c8b352688..b238315b7dcc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.20.104.tar.gz 7883624 BLAKE2B 4fb4c6abff5a2c3d3e19b11576e723f15a442b2d49e461a2a4c2bd613e26095ceb87f4b7ceb672f338ea04ad918060bed118f7bc4c184c46cce1d6a9f98d4239 SHA512 2201d87ce2e1c8979548698d6a46eb03c0a2026360b178fea895ad6a244efad534d9970d3c6343d50639d25b3b8643db6744658fec14e0fa29fd7c4b45c8e0d8
DIST botocore-1.20.112.tar.gz 7917776 BLAKE2B 6a5ebf3d32c505ec2c1fc4cd3d97aa94c76b6206dda6ba28a946dfdc9973073019389c05d1cf09a0eced701fe86a9b8a292835415c0b1ceea75959a3186f65c6 SHA512 4b36367ffdd011aeb7654fd5c52c38e95bae4c55e5af85e38b0764140539ad1f8b9d75b0c7fd1009fda8d005ef4b17673b06f85a76b52fcebf05925297b6bbbf
DIST botocore-1.21.0.tar.gz 7955550 BLAKE2B 7e68375d07d858dc2071538c2382d8693df23fea5326938491c492abe55c060d0cdf98698cef9b06dac996a59c907ed780e5baadabbb7c10d5e41efa84c4750c SHA512 e56eea7f3c4f39f51ef1d53dfb42fd5d601167cca7c868b1cf2f291732a8cf90aaa874760f262085439df5726c6b610369a325e863533b593aa708fd901398a1
+DIST botocore-1.21.1.tar.gz 7954248 BLAKE2B d6e7a71d6dd90ed0fcf0dbab3182dcdfa4072e65a1f344d44ac30abc829ac6c546a0ebcdee51f61ae65008550acf65052b49530ae3b3a62d81af222e6e8a0929 SHA512 86d4b4159a96426e7ab853b06564604fd9729011199ba691f6204a7e5f52d9927b93511b73cfc03b65bce706563c6d50b577d85d0de0e50fb5d877472d8326dc
diff --git a/dev-python/botocore/botocore-1.21.1.ebuild b/dev-python/botocore/botocore-1.21.1.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}