summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-15 22:26:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-15 23:07:27 +0200
commit50e00a9743848599c7f2ddc6b39ae5294c297e6d (patch)
tree5dee469db768612d308f061b3ae4692691d33e81 /dev-python/botocore
parentpackage.mask: Release gnome-shell-41, evolution-3.42 and co to ~arch (diff)
downloadgentoo-50e00a9743848599c7f2ddc6b39ae5294c297e6d.tar.gz
gentoo-50e00a9743848599c7f2ddc6b39ae5294c297e6d.tar.bz2
gentoo-50e00a9743848599c7f2ddc6b39ae5294c297e6d.zip
dev-python/botocore: Bump to 1.21.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.63.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a478b962b34c..8f4f98f08d1f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.21.53.tar.gz 8221904 BLAKE2B 79a87c9678fad9f3b4503740d9857579850
DIST botocore-1.21.60.tar.gz 8253381 BLAKE2B f035a335f8d72c182f6fbd3f2216608bd5683e70ae11fd8646ff81416262ec802aac5b084f0cf96d23fd6767bbe678e35b24377d82186440b3ee55c977b42643 SHA512 7e801f67c670a85ebd0641fe8a51890dcea1a3a6f2253cca1213ee96a20497c1196c16b2576bcd2dc796b501117d609240c59b1077bbdc0f3021cf6659289e21
DIST botocore-1.21.61.tar.gz 8255275 BLAKE2B 53f5e6c3af455bd92f59152d28ed7a598c1743c9cc648bf28922ce2833f53f7fa01de052109225117cc52126593bf51ca56765d35d1e25ced2a4a2a2f88326c5 SHA512 8cd110f78acb1dfc29f9eda5bcecdecba07e2846faab063c8d86294ae81935783e62c66f7588d505a2f6ca69445eaa80835011ac7b19e975e8dce9f65b28b429
DIST botocore-1.21.62.tar.gz 8256122 BLAKE2B cf51c1aa4890dd3deb9da8b4c51b89cd4c006ec604d7728304938833c156450829693daa563f59a09f066428348f70f5d8b94172341ac30be072443f6330b612 SHA512 c34e512d1ebc60e7c37d3fb6856e43affbfc77cc21c971547725277df5325d8ae20acbf00fe2e89fc2c564d8a911a6a0db913c9ab6bd769e38596f2d8eba36b4
+DIST botocore-1.21.63.tar.gz 8256427 BLAKE2B 7b6a4d29005cdf127881a88b51ffb3162698df011d7345137537666e92a01a00e44c0fc7edc8ec4c17d3d30ddc5ae801b253b0704e70c37f6de1979cd2fe86fb SHA512 e67b56d3549bd70101f322da04eacca261c2afe9cd2c065ac290b4266fed5342cb8f15a2edc144006c5dc91692a95ac49d9d2fde86db4014511bdc3bd95d9193
diff --git a/dev-python/botocore/botocore-1.21.63.ebuild b/dev-python/botocore/botocore-1.21.63.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.63.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}