summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-06 09:13:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-06 09:32:55 +0200
commit51ba9413eca04bfa0d9bbae0ef591fcb4e368062 (patch)
treec915d799776fdd83ca7dd49349c0c76ec2f04e99 /dev-python/botocore
parentdev-python/google-apitools: Bump to 0.5.32 (diff)
downloadgentoo-51ba9413eca04bfa0d9bbae0ef591fcb4e368062.tar.gz
gentoo-51ba9413eca04bfa0d9bbae0ef591fcb4e368062.tar.bz2
gentoo-51ba9413eca04bfa0d9bbae0ef591fcb4e368062.zip
dev-python/botocore: Bump to 1.20.67
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.67.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index bada8c6ac053..10b3cc55960e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -16,3 +16,4 @@ DIST botocore-1.20.61.tar.gz 7668184 BLAKE2B 2b48af271b0a7c90f18de0e1742fbf5a7fa
DIST botocore-1.20.62.tar.gz 7674812 BLAKE2B 6fec1213c13bc12937f45c2584ce52532ea75d6973e9741d18933dc399e8f0ec569d6aacdf4a9f83f997ff9898cb39c327410965d992836bbfbd9aa06ea81311 SHA512 ae25e2266955964de7be499fe17b64dd5008b1c1abec84167593b04a1bd4f7baa506f91013b292cd42aae01990ec3523d75e3529398185fdaedc358bb5048e83
DIST botocore-1.20.64.tar.gz 7685481 BLAKE2B d939b262f04a67918fe61ba0789a4ac9a73bd571096fde881ad537bd7b193798960096ea6d966b49634f33454845c8227786c7bb16c0008e8b5dd84591c2e018 SHA512 a2e82988e59f05ae7050b3e8f86b379dde83f516736c9ca133c0fa678cb7c6ba5448e2165cb0ab3f4262e8e3681ede37048508092ba62313e6ce3f89700c8827
DIST botocore-1.20.65.tar.gz 7689179 BLAKE2B 4f831519c785747b48351b9820fe00efb39ae9157ff11604b6d850b9768a6613ad54b3db9071dedf51e0e9209f3741f35d7e21e953842d1bc89db52b22779d41 SHA512 1936955ab69aaa7d82ea2dc522603162b00e3a9ca39b5911ccd4f3d78688ff1375c4e2abc65638a517a5d7a07076c1c7d6fb81529c6d5cfbe9c13254c3736777
+DIST botocore-1.20.67.tar.gz 7691087 BLAKE2B b56cb7e80179b7c5c2b4daa27907870c075b0cc5b0c14da1d96583701df6d764f0e80cff7973f501263a4edd4e70e4adb613cbe7fa05d7855602db508b509539 SHA512 d0feea0042ef5bbe1fc76ca107cb2450bdf564d82542c483f3b484aa3e32986d649bea9e7e65ea7a36e23582c73c7b341bdb1b07722f09b67334b97ca423999c
diff --git a/dev-python/botocore/botocore-1.20.67.ebuild b/dev-python/botocore/botocore-1.20.67.ebuild
new file mode 100644
index 000000000000..f051cb0e68ac
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.67.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.20.64-bpo43882.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}