summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:34:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:15 +0200
commit63bbec88698a5b6952014b41481efcd5417040bb (patch)
tree1c78e43e7216e2f9e97f319676b35f7302acd619 /dev-python/botocore
parentdev-python/podcastparser: Bump to 0.6.8 (diff)
downloadgentoo-63bbec88698a5b6952014b41481efcd5417040bb.tar.gz
gentoo-63bbec88698a5b6952014b41481efcd5417040bb.tar.bz2
gentoo-63bbec88698a5b6952014b41481efcd5417040bb.zip
dev-python/botocore: Bump to 1.21.46
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.46.ebuild58
-rw-r--r--dev-python/botocore/botocore-9999.ebuild5
3 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 66ac74536351..4e6b06632cd5 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.21.42.tar.gz 8156403 BLAKE2B 199d1eeae7b51fc59b8ca6ed3ea331178e9
DIST botocore-1.21.43.tar.gz 8167256 BLAKE2B 525f0d1e7cacd34d81800abf5a120cdaff2a5ba91dfe7e7405d54d8b1768b45df4b1d36b287ab1db42ad68f17f1f2bfcd5c71c64a270824c69128fafea8ec113 SHA512 709f1792f855bb4178dd2d1e79f7b476e5b695a84684d9a5e6e57a36bd8f881f28cc4322a2e296c3935fad544d6adb4ede15a7cd532c7e5671350f0d96bee105
DIST botocore-1.21.44.tar.gz 8168012 BLAKE2B c1fc1a2cb71c88365b18f578cde18633a7969b7d12c8162762fdc1ad9395ebf859a9d144870a751a1760f93bffd255bb8969b1fde812f9bf1d95e9973b61b202 SHA512 66b4c3ede4b23260a61309de7afcef2c5436516b3399c52438bae50b8714e3d8b0c86b271e0ac8f1214738ecee3e1677fa6ca7315a1bfaae5a49f2aa650a6806
DIST botocore-1.21.45.tar.gz 8170610 BLAKE2B e55cc819188ae61c1427a3a7e3ff008d85c8590e37873940a2749fb7b07431f5ce828e403f294c53ccd7b7c6fa8ce82265773a5e2c1ca85b00449d77557aed7b SHA512 54d7a450777bba7db5633b5591c446533444f3d12704deaf4d039603c5bbf8c3cb5c0fa88cddaf58df21f3dc2fb1fdf9b90cc63e0ef5967f535b761b7c136d6d
+DIST botocore-1.21.46.tar.gz 8175719 BLAKE2B 8c171e07e5c68b1d3721c0d5052b09d2c5522f0ed899453441e72c744e117f7479995ff2fde222c2c1fdcfe382464b9bc0898367a3d79b1e53dbfc60d855e10c SHA512 3ec64d160ec682d287fc1cadeb5ef4ed50a3157f98cd18514d75ec9e60ea73b4dde5a419e7a07c490216d8d67c29d214b88ff9fa1ef3a8b0bf176f11fb9cfcab
diff --git a/dev-python/botocore/botocore-1.21.46.ebuild b/dev-python/botocore/botocore-1.21.46.ebuild
new file mode 100644
index 000000000000..cb37cb422ac5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.46.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 762144aabf71..cb37cb422ac5 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Low-level, data-driven core of boto 3"
@@ -27,7 +27,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
)
"