summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-27 23:20:50 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-28 00:15:53 +0200
commit72ba8e9499e602ebda8527469f89cf5d884722e1 (patch)
tree1f5c245eb0ef8002367e2ef93923efad389aaa22 /dev-python/botocore
parentsys-apps/baselayout: 2.8 bump (no keywords) (diff)
downloadgentoo-72ba8e9499e602ebda8527469f89cf5d884722e1.tar.gz
gentoo-72ba8e9499e602ebda8527469f89cf5d884722e1.tar.bz2
gentoo-72ba8e9499e602ebda8527469f89cf5d884722e1.zip
dev-python/botocore: Bump to 1.21.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.49.ebuild50
-rw-r--r--dev-python/botocore/botocore-9999.ebuild12
3 files changed, 53 insertions, 10 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index bc912a631736..2695ca34d188 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.21.45.tar.gz 8170610 BLAKE2B e55cc819188ae61c1427a3a7e3ff008d85c
DIST botocore-1.21.46.tar.gz 8175719 BLAKE2B 8c171e07e5c68b1d3721c0d5052b09d2c5522f0ed899453441e72c744e117f7479995ff2fde222c2c1fdcfe382464b9bc0898367a3d79b1e53dbfc60d855e10c SHA512 3ec64d160ec682d287fc1cadeb5ef4ed50a3157f98cd18514d75ec9e60ea73b4dde5a419e7a07c490216d8d67c29d214b88ff9fa1ef3a8b0bf176f11fb9cfcab
DIST botocore-1.21.47.tar.gz 8183951 BLAKE2B 930fdccd5d45fb1fb88fec2370e65bff5eb7241ea3a666f1f0bfeb11ee3e1e5bb715d658ac1f340c0565f16bbba48fa57c7460aef0e0595486303f62f79df244 SHA512 705fa363bdd4663f774e349e448666d7bfd47c77b57689d6cc12039419c8a4f820d7edd01de9689cd56fee3d59138ea9bd803b4402c8b5fac95cd2de76fb1558
DIST botocore-1.21.48.tar.gz 8180642 BLAKE2B 9efa407e69caebd7a8c8f058c356b024ac5f7ad1675c099bef1f593b391aab5901853e4c0b0a9989ac190bdbc8e869a2f0dd2670ce483f14f1f2b993971c4652 SHA512 1319679897ec3ed07a489a52d0d3e6a9abc529bb1c1aa458f1b51d1035d7e8bc203ba830fef2354fd07f058b3bb4ba140af34cb1616b509ecda08f5a18b2ed49
+DIST botocore-1.21.49.tar.gz 8202118 BLAKE2B cdda23ddbd1d9540c8dc1e53763bfccf9984a8df65683f1bb9e7541beca866beba75fd76a983c14c953224cdc19749b0e0af7e17529b4bd41869b5a2bfa49d0a SHA512 4a85a0bef518b57942b57fe01b10c588c3cceb1d8c7fa14e4bdc2e0c53fd3bf5b19947659870ce4af57bdabc4036d9a8c15b53530b7ec312e33b5bb91a784781
diff --git a/dev-python/botocore/botocore-1.21.49.ebuild b/dev-python/botocore/botocore-1.21.49.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.49.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index cb37cb422ac5..638620b2cbc8 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -37,22 +37,14 @@ PATCHES=(
distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests nose
+distutils_enable_tests pytest
src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die
- # very unstable
- sed -i -e 's:test_stress_test_token_bucket:_&:' \
- tests/functional/retries/test_bucket.py || die
distutils-r1_src_prepare
}
python_test() {
- # note: suites need to be run separately as one of the unit tests
- # seems to be leaking mocks and breaking a few functional tests
- nosetests -v tests/unit ||
- die "unit tests failed under ${EPYTHON}"
- nosetests -v tests/functional ||
- die "functional tests failed under ${EPYTHON}"
+ epytest tests/{functional,unit}
}