summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-24 08:24:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-24 08:59:00 +0200
commit78fc79559917df6b1077a781fb29c5b5be820e86 (patch)
tree40016d9cf0c56db4e8a5053323bae08a7a68b00f /dev-python/botocore
parentdev-python/aesara: Bump to 2.2.1 (diff)
downloadgentoo-78fc79559917df6b1077a781fb29c5b5be820e86.tar.gz
gentoo-78fc79559917df6b1077a781fb29c5b5be820e86.tar.bz2
gentoo-78fc79559917df6b1077a781fb29c5b5be820e86.zip
dev-python/botocore: Bump to 1.21.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.27.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 449b0865b82e..fd9a2c05bf97 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,4 +3,5 @@ DIST botocore-1.21.21.tar.gz 8042971 BLAKE2B 888abb929e1d66c293bff9d3d25682590e0
DIST botocore-1.21.24.tar.gz 8048949 BLAKE2B 2948da75d445114d5489d3f7cef1d8bef9324da8699f69092eeb4c65a9be0fd82aae4ee97498f09d7cac05e33bc53fbd6720849a309c5edad96eba5450b45cd0 SHA512 6c205a0c27f9602580de7fbacee476b2855599bdd017f3c010f07b8f48a2ffd6acbce48f661d22ef0ebe30baba9db1ae65b1bea6afa3ae1a1c3add92abbd1478
DIST botocore-1.21.25.tar.gz 8063998 BLAKE2B b3e4563cd36825468b6c7755fa101d13260519240b856fa26166d5bb034352431a29e816dc9e7d60f4c10e9d3b5fd152342749cc19a75a9c35ba228023da3f48 SHA512 cf91fc16047d0168d743db5bd95003a2ae06dc72ca586c622690e8c7be546bca050ba81eaf49fd860eb42e3a0046ef99e3927772b6893ddfdaf57a1071489714
DIST botocore-1.21.26.tar.gz 8065456 BLAKE2B d6cd96e35ae31e6c440abad2a76f23d2ce6e2e0d5ecbe275fc0404cebaaf0a14245735adc39cc6d7fe5feb9530120cfa403f061af3c188623f6ba1ad01cd8d12 SHA512 3b57a6bcbdb018f0bc20afec8844f07f7135658b29329d0ed4d5579db1a8cc05e5725335560f5786b77c2f7590879ed7dcf6c043e0efd3f16960689c64f1b061
+DIST botocore-1.21.27.tar.gz 8076120 BLAKE2B e7928438ec4b100ef00d202899fae47c7bba4a351206172598718fa042c61c3d84a7559e45fe41ef4e736639faa538220b22d74c8652d980b4c339489129d793 SHA512 32f03f274329741096f3c82181dfbf6c337189e04db0890baf834364a6aedc09b33c1a0936fe53c6e51197d0f2385269dc2f3f8f75e62f260a11dba970ee6d0d
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.27.ebuild b/dev-python/botocore/botocore-1.21.27.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.27.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}