summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 09:24:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 10:00:51 +0200
commit858e9f672dbea7ac8692b349b636b3bfb1a1b820 (patch)
treea21df74310f617ef74a7710bcc3c663b4b069d13 /dev-python/botocore
parentmedia-libs/ganv: removed obsolete 1.6.0 (diff)
downloadgentoo-858e9f672dbea7ac8692b349b636b3bfb1a1b820.tar.gz
gentoo-858e9f672dbea7ac8692b349b636b3bfb1a1b820.tar.bz2
gentoo-858e9f672dbea7ac8692b349b636b3bfb1a1b820.zip
dev-python/botocore: Bump to 1.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.18.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index e0316f816cef..9fba0db04f4e 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.17.57.tar.gz 6815839 BLAKE2B e135e4d0b889add8417d8a6ce97c4758658
DIST botocore-1.17.59.tar.gz 6829639 BLAKE2B efacd4c875e17f187abd5c4602a82229ed2a9fd78e1987f1b540eb882d1a3ce7c23768f7f4b9dc26a678ff4ce48264f3893c0aa2a68511823f79686c21ecf82f SHA512 609eb24774384b95dd9b5bcf5931d263341fbbba90b84159c6833296c22d95c6cf8d304d6908713d9ba826858d8d226e0b5c700bb1410c3a9f7b2d679f535c40
DIST botocore-1.17.61.tar.gz 6832886 BLAKE2B 1c63507dea98f4f4275effe190e7af1e3325ee03376676bdbab6eeca364540bd86c7253b1ab64a70d28cf2f5ae8182927c2f18ac86e0bac813d4ef11c37193c6 SHA512 606076103594fb6efee1fa79181449c0ffa37eb71b5f5c187f8046375ddf982f72741ba00a1d2311be893094b86dd9196ee33410a693727ea9502cf87332dcc0
DIST botocore-1.17.63.tar.gz 6841028 BLAKE2B 89b2d5d520e733deaf3c4b68faa103e4227107cebd3803d1cb6e47ec0df9f7a07d72eb24836a45762ead2ce1aa381d5b1dfcc33eb9a80c5f8d021c0dbfb631c3 SHA512 e4cf3fbb4c8a5c05dc8265b67fbba0bf03dcf12d28bcd0e1dd304392614d86f061a5115f8129eefa2fa44efab17a8720b7c39c082c2908bf4e29bbefb57e92fb
+DIST botocore-1.18.0.tar.gz 6838497 BLAKE2B efc0930b8ffafdf8d7f24d4f30cbf12e0dd81aa4ae405beee7663271fe8ffe680df91d40f8629b75635fae87ad29f0186e42f11e4bfebc64cc58979edd74e64b SHA512 43b5992d1ffb8d10f32f532c3085825e3775e3da4d6c25c2e300dfcd6e24967bdd318a7be37889a9d7802eb74bd9085b9642cda099b0064cbd9ffd65a56b7de5
diff --git a/dev-python/botocore/botocore-1.18.0.ebuild b/dev-python/botocore/botocore-1.18.0.ebuild
new file mode 100644
index 000000000000..ba67bf7ac94b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.18.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}