summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-25 08:32:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-25 09:45:10 +0200
commitbf107d3b04fae332d092871c8d2fd7d9f540fd0e (patch)
treeefa3d7c0cad9845e34e9c5d822458185292b4ea1 /dev-python/botocore
parentdev-python/django-filter: fix PYTHON_USEDEP (diff)
downloadgentoo-bf107d3b04fae332d092871c8d2fd7d9f540fd0e.tar.gz
gentoo-bf107d3b04fae332d092871c8d2fd7d9f540fd0e.tar.bz2
gentoo-bf107d3b04fae332d092871c8d2fd7d9f540fd0e.zip
dev-python/botocore: Bump to 1.21.48
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.48.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 01c969b08deb..bc912a631736 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,3 +7,4 @@ DIST botocore-1.21.44.tar.gz 8168012 BLAKE2B c1fc1a2cb71c88365b18f578cde18633a79
DIST botocore-1.21.45.tar.gz 8170610 BLAKE2B e55cc819188ae61c1427a3a7e3ff008d85c8590e37873940a2749fb7b07431f5ce828e403f294c53ccd7b7c6fa8ce82265773a5e2c1ca85b00449d77557aed7b SHA512 54d7a450777bba7db5633b5591c446533444f3d12704deaf4d039603c5bbf8c3cb5c0fa88cddaf58df21f3dc2fb1fdf9b90cc63e0ef5967f535b761b7c136d6d
DIST botocore-1.21.46.tar.gz 8175719 BLAKE2B 8c171e07e5c68b1d3721c0d5052b09d2c5522f0ed899453441e72c744e117f7479995ff2fde222c2c1fdcfe382464b9bc0898367a3d79b1e53dbfc60d855e10c SHA512 3ec64d160ec682d287fc1cadeb5ef4ed50a3157f98cd18514d75ec9e60ea73b4dde5a419e7a07c490216d8d67c29d214b88ff9fa1ef3a8b0bf176f11fb9cfcab
DIST botocore-1.21.47.tar.gz 8183951 BLAKE2B 930fdccd5d45fb1fb88fec2370e65bff5eb7241ea3a666f1f0bfeb11ee3e1e5bb715d658ac1f340c0565f16bbba48fa57c7460aef0e0595486303f62f79df244 SHA512 705fa363bdd4663f774e349e448666d7bfd47c77b57689d6cc12039419c8a4f820d7edd01de9689cd56fee3d59138ea9bd803b4402c8b5fac95cd2de76fb1558
+DIST botocore-1.21.48.tar.gz 8180642 BLAKE2B 9efa407e69caebd7a8c8f058c356b024ac5f7ad1675c099bef1f593b391aab5901853e4c0b0a9989ac190bdbc8e869a2f0dd2670ce483f14f1f2b993971c4652 SHA512 1319679897ec3ed07a489a52d0d3e6a9abc529bb1c1aa458f1b51d1035d7e8bc203ba830fef2354fd07f058b3bb4ba140af34cb1616b509ecda08f5a18b2ed49
diff --git a/dev-python/botocore/botocore-1.21.48.ebuild b/dev-python/botocore/botocore-1.21.48.ebuild
new file mode 100644
index 000000000000..cb37cb422ac5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.48.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}