summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-29 23:17:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-29 23:59:29 +0200
commitc30e3dcacfb73ff72ae74fdf2d31f640735e043e (patch)
tree8b56e6904fc475b4e10d3a2e8cc89b383dfd585c /dev-python/botocore
parentdev-python/pyproject2setuppy: Added ~mips to KEYWORDS (diff)
downloadgentoo-c30e3dcacfb73ff72ae74fdf2d31f640735e043e.tar.gz
gentoo-c30e3dcacfb73ff72ae74fdf2d31f640735e043e.tar.bz2
gentoo-c30e3dcacfb73ff72ae74fdf2d31f640735e043e.zip
dev-python/botocore: Bump to 1.21.51
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.51.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 1ef4479393cf..caa689838c95 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.21.47.tar.gz 8183951 BLAKE2B 930fdccd5d45fb1fb88fec2370e65bff5eb
DIST botocore-1.21.48.tar.gz 8180642 BLAKE2B 9efa407e69caebd7a8c8f058c356b024ac5f7ad1675c099bef1f593b391aab5901853e4c0b0a9989ac190bdbc8e869a2f0dd2670ce483f14f1f2b993971c4652 SHA512 1319679897ec3ed07a489a52d0d3e6a9abc529bb1c1aa458f1b51d1035d7e8bc203ba830fef2354fd07f058b3bb4ba140af34cb1616b509ecda08f5a18b2ed49
DIST botocore-1.21.49.tar.gz 8202118 BLAKE2B cdda23ddbd1d9540c8dc1e53763bfccf9984a8df65683f1bb9e7541beca866beba75fd76a983c14c953224cdc19749b0e0af7e17529b4bd41869b5a2bfa49d0a SHA512 4a85a0bef518b57942b57fe01b10c588c3cceb1d8c7fa14e4bdc2e0c53fd3bf5b19947659870ce4af57bdabc4036d9a8c15b53530b7ec312e33b5bb91a784781
DIST botocore-1.21.50.tar.gz 8204209 BLAKE2B a2db3a93696d6be68268265a7dbd1809edcaf9a3039974d55d718a86a3f9c8a08342f54ec9a491cdb0d32b6bb5505bc17e21d43fa8be2a93b34cc8305fb06b55 SHA512 b487a0463159d6e9109f8d195a567c0c086f705406b52554f2f18ccd57aff6e116e9176716a79f5d24066a43a8193ec088fdd4671df69d6c23102537b59c4f7d
+DIST botocore-1.21.51.tar.gz 8204164 BLAKE2B cf9a74b509ee721d19dc3c2f3e6c1ed5f571ea35ab813402d13d285c5f465f8146b1fe3ca99b863e4eb48574034ccadca6dfd0cc118f267ea917d4822f1bfa73 SHA512 4835bfcceb14a46315afdd74ee8015d51c951c4dd8e8b49fbbd9c02bbfd2958925b52661a65a9a26be6c386e2d251bea4322a8f9c3749d4815f2efdb97e403f8
diff --git a/dev-python/botocore/botocore-1.21.51.ebuild b/dev-python/botocore/botocore-1.21.51.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.51.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}