summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 08:41:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 09:09:06 +0200
commitc30f9896e0a6bb8d662ce2ec3dcc15352eb4d9e7 (patch)
tree3c8bf4996754bbae24e94ba8b8a523217ba63f19 /dev-python/botocore
parentdev-python/ruamel-yaml: Bump to 0.17.14 (diff)
downloadgentoo-c30f9896e0a6bb8d662ce2ec3dcc15352eb4d9e7.tar.gz
gentoo-c30f9896e0a6bb8d662ce2ec3dcc15352eb4d9e7.tar.bz2
gentoo-c30f9896e0a6bb8d662ce2ec3dcc15352eb4d9e7.zip
dev-python/botocore: Bump to 1.21.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.29.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b6ccc751b81f..a9db4d40fbb1 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,4 +5,5 @@ DIST botocore-1.21.25.tar.gz 8063998 BLAKE2B b3e4563cd36825468b6c7755fa101d13260
DIST botocore-1.21.26.tar.gz 8065456 BLAKE2B d6cd96e35ae31e6c440abad2a76f23d2ce6e2e0d5ecbe275fc0404cebaaf0a14245735adc39cc6d7fe5feb9530120cfa403f061af3c188623f6ba1ad01cd8d12 SHA512 3b57a6bcbdb018f0bc20afec8844f07f7135658b29329d0ed4d5579db1a8cc05e5725335560f5786b77c2f7590879ed7dcf6c043e0efd3f16960689c64f1b061
DIST botocore-1.21.27.tar.gz 8076120 BLAKE2B e7928438ec4b100ef00d202899fae47c7bba4a351206172598718fa042c61c3d84a7559e45fe41ef4e736639faa538220b22d74c8652d980b4c339489129d793 SHA512 32f03f274329741096f3c82181dfbf6c337189e04db0890baf834364a6aedc09b33c1a0936fe53c6e51197d0f2385269dc2f3f8f75e62f260a11dba970ee6d0d
DIST botocore-1.21.28.tar.gz 8079306 BLAKE2B 26dce445746a9da1b0cf62b622597396f9b4e735701f9260fd9863410b28b884e70e41b446b8349df39c81696b64632450f4ebb3e3f7865175e538f1b465898c SHA512 29534e51465bc7ac7b6f2e2c48472768c26caa5089f4c7f4a23cc2411fd55fde473388ad181a0b5a36650a6c1252ecb3e2b65e30510adc40f6edd6ce0c89f484
+DIST botocore-1.21.29.tar.gz 8079625 BLAKE2B c396b453893782f94e503cb581efe5beb2a5766beb46b5c0840db3cea3d14b637a49c0cbf8971dc3fc4aa6899cdbaffac882cf3f889e78c25f0b5195de947925 SHA512 0b791b14e81158dbaaac0f39c0f1eba3f67b4a75ef97bbeff2a9eecf9b5c436268ae4a2ff0834bb00628497e06539148c22621a61ba6df9d44b988e17a67b329
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.29.ebuild b/dev-python/botocore/botocore-1.21.29.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.29.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}