summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-13 11:09:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-13 11:09:38 +0200
commitd1684bf04d20a1d1645cf801b5c2b45de84a0f21 (patch)
tree27ef2c7627dbf589d532e2057c1152c442b75973 /dev-python/botocore
parentdev-python/google-api-python-client: Bump to 2.26.1 (diff)
downloadgentoo-d1684bf04d20a1d1645cf801b5c2b45de84a0f21.tar.gz
gentoo-d1684bf04d20a1d1645cf801b5c2b45de84a0f21.tar.bz2
gentoo-d1684bf04d20a1d1645cf801b5c2b45de84a0f21.zip
dev-python/botocore: Bump to 1.21.60
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.60.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index a9a072b4dc46..5e8cba44e4ee 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -8,3 +8,4 @@ DIST botocore-1.21.56.tar.gz 8227172 BLAKE2B 0a783e76c0a4a3ea577661a5995fdb2e536
DIST botocore-1.21.57.tar.gz 8239528 BLAKE2B d2b98f37468e0faf593d5fd42341dcab32d7ade253c80929722adbe7523ed6efb2b491a12b4335faf779703acc6eabbd3e1c6e0a02994d24dd13cea7d376bf6e SHA512 6bfcd57c7ac77c1098004e5e8a77c14a3718099eda5af00fbcaa0f54fabd93caf0ce66212c5807ae58d565cadfee25dfdcff9dcef8a68e66ba74f03ee28acfb9
DIST botocore-1.21.58.tar.gz 8243903 BLAKE2B a8666451aa7e39114afce45d1eb82fed8f1747b6f994dc5ec76f8c675c363fd196c2c23d26738ca2a1c67e451d2eff1024d01ef97ff0dfb425d8fa85a9c0eef6 SHA512 424f13d7f3c5c2b3b2546cf42f22588a53c407867c8e2672c01f6c3791d101ff42f5d7a300cffbcccafdfc78f28a4386ef9acc4562de3c124198d1c898e5701d
DIST botocore-1.21.59.tar.gz 8247144 BLAKE2B 6c3a5030be52dd59c6aa02baa13766134957c929cebf5332b0ba506e7cc0698b38062b37149367e405633ddd35ed7b0b2977500c5f9416eeafa6107f5536f03e SHA512 9675824c6509fb102bc124a8cf35329f2742526381d4f8966a6ef7dd21ac37b15f386f8c1f268f5528732d81d8b853ab5f1b96e869ab1d3bed099f2e871aa43d
+DIST botocore-1.21.60.tar.gz 8253381 BLAKE2B f035a335f8d72c182f6fbd3f2216608bd5683e70ae11fd8646ff81416262ec802aac5b084f0cf96d23fd6767bbe678e35b24377d82186440b3ee55c977b42643 SHA512 7e801f67c670a85ebd0641fe8a51890dcea1a3a6f2253cca1213ee96a20497c1196c16b2576bcd2dc796b501117d609240c59b1077bbdc0f3021cf6659289e21
diff --git a/dev-python/botocore/botocore-1.21.60.ebuild b/dev-python/botocore/botocore-1.21.60.ebuild
new file mode 100644
index 000000000000..638620b2cbc8
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.60.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}