summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-01 06:42:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-01 06:55:16 +0200
commitd26a9d62e3b90ac7d0e92aed826f9f2e68b28e94 (patch)
tree249dbe45754a78b0097906a2914d1973bd2e65f0 /dev-python/botocore
parentdev-python/ipywidgets: Bump to 7.6.4 (diff)
downloadgentoo-d26a9d62e3b90ac7d0e92aed826f9f2e68b28e94.tar.gz
gentoo-d26a9d62e3b90ac7d0e92aed826f9f2e68b28e94.tar.bz2
gentoo-d26a9d62e3b90ac7d0e92aed826f9f2e68b28e94.zip
dev-python/botocore: Bump to 1.21.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.33.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 69faa881bda4..f3627fc5d685 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,4 +9,5 @@ DIST botocore-1.21.29.tar.gz 8079625 BLAKE2B c396b453893782f94e503cb581efe5beb2a
DIST botocore-1.21.30.tar.gz 8081027 BLAKE2B 6566d74873c08ce84f6bd0e6a802e62c6cf21956136f2e3991e1b498c3ac4f6a11b17a3d8b44595f4d4b5ef5e9b2a6bd71802e5f0270b8cc1473e8fc94e0db5c SHA512 fdc4991ac8fccb71c82542b05c25edba1607381289e384786079bd3b9efda527e0aecccd29fc372ff5b8d265a204fc570bbf7191683a36d9cb9e43a2153fe685
DIST botocore-1.21.31.tar.gz 8081621 BLAKE2B 78bd0ad2d1371582e97c8ddddb9a0b9f41fd75d701ba2ad49fab0e6f3d4602eb6a06bb51f23f674ef71d8c0bcec39ab545071ec8ef252df1c9d9133d8223a746 SHA512 bdaa85ad59936334e8d0e57a0e6631bb1c4408a0b9a50eb883b9b9dc5df4845da2df0fc64af755c5bb2ce5ee667c449a751263e25c9912bcb335eaa41cbba95e
DIST botocore-1.21.32.tar.gz 8083411 BLAKE2B f43cffb2b8dba99e9d893dc6842593525a5545878b52680f8418f86f01f1804dfd1439087092a71d1d9933b63e09615c781e52be8eb5176fb18d1808f0125d18 SHA512 a6d8ca645c3b00b04579be86febd232eac8929f1b58582948208d5b1cc82686c76327302c7459123be8e7a44bece1249ece58fe47619082916e383c0ee6c11a9
+DIST botocore-1.21.33.tar.gz 8091142 BLAKE2B 832df8535696227ccd0cfbe16d6084048b5d409f117a1142d97296107466371782ff20d8bd3fbf3bd8a90fe5c23e3b746e55a99014c7203dd5c7c1c1b17fbbb8 SHA512 6618f6b53664a62d10b5edd1845880655e88ff8ef7ed2b35ac0a9b18f0135302d148c12cdc6e588f25a328ac8da5e88174873a021078e8be3dc542da7e1579a8
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.33.ebuild b/dev-python/botocore/botocore-1.21.33.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.33.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}