summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-14 07:50:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-14 10:03:21 +0200
commitdcc369e5d1d61840e169c4e8f8d56ac8bd366b8d (patch)
tree8498db0febc96c40475d8fe875584c1feb5dc876 /dev-python/botocore
parentdev-python/importlib_metadata: Bump to 4.6.4 (diff)
downloadgentoo-dcc369e5d1d61840e169c4e8f8d56ac8bd366b8d.tar.gz
gentoo-dcc369e5d1d61840e169c4e8f8d56ac8bd366b8d.tar.bz2
gentoo-dcc369e5d1d61840e169c4e8f8d56ac8bd366b8d.zip
dev-python/botocore: Bump to 1.21.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.21.21.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 11c9d8bac50e..a8b44a9b2bfa 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,4 +3,5 @@ DIST botocore-1.21.15.tar.gz 8012673 BLAKE2B cdd2b4128e67c85879e85f61265b10c1e57
DIST botocore-1.21.18.tar.gz 8034404 BLAKE2B f28cd392a0ca34bc5baa6316bcc9b040ab7cf429c6b16b1c9cb832d310640a75df21ac22634a565d91eeefcb1476f50487e2e80b52cfbfca1cdb9683e76d801f SHA512 485e3d293684659731061592082582678035ad657fe47cacd9f7608cf09d801bfd73951a3c0de77c65a79e6070638f0b3dddfa357d7f0ddbb773c70334b214b8
DIST botocore-1.21.19.tar.gz 8042956 BLAKE2B 69f1ac5ad0282308998374fb4625c3a4e1203dc338c4f945b75f8c18c02754b02fdf88e65e9333876ea6495d7d2ee45e2b6592f6602676ace57f65b5f3fe6fd0 SHA512 2fcb1e8879ef963c54100e81923a05bef2830238c67f44f0627003be65335a019153c4537d375a54e5f180ac37cf99f30bef3b4f41edd350259128de48d1ea74
DIST botocore-1.21.20.tar.gz 8041821 BLAKE2B 3691f5bf248c3d9d63e0ae46ce460e9d72662c1b6c526048cd2cf5ee4868892a2e86b41b37abd9fa8e9f90be92a1a171bc260a4de97de110aa3aea35f0170120 SHA512 b142fc293242f7364dfb29837436f84371c44289547668446a31180eae3615b31da6cc3a0634bca6d8cbebc990524009fd059b492979fb76250338d952fc99e1
+DIST botocore-1.21.21.tar.gz 8042971 BLAKE2B 888abb929e1d66c293bff9d3d25682590e0fce3173ca6e121b969d1ef92dd4bb3fd010f72ab4bed664ed6e2df94fd61a9211a3aad72742eb1d4ee2b192cb4f7d SHA512 f8f47c2a2ed07f90263fd5eefe593bf14e8bb2a8df599660f2c84c504a16eb1c370ff8edea0b809be34f1fe9c7e8a3d604b74689b9e16c0686e6ff7c640534a4
DIST botocore-1.21.7.tar.gz 7977343 BLAKE2B 19c5bf5de40ab131585e30bb85486fcffc3428808811b312b33578174ce31a691f4f4d955462120f05d2aad2cd5e5772789704eee641760fb67099aa3cddc9b5 SHA512 db1bb36faa6857a1cc717e5d591954415bb948178ee2be90ab9c32c11b1fb45c5b5aff87dfacd907c2f11bc7cdd2cd4de2ee9c847fa8cda4e5f0814a828b1019
diff --git a/dev-python/botocore/botocore-1.21.21.ebuild b/dev-python/botocore/botocore-1.21.21.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.21.21.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}