summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 08:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 08:47:54 +0100
commite4f97611326f8dd7fcab41e1feddedd25e8d6644 (patch)
tree5a49f3669d579689c0d46c0f2a34fbe75ca248e9 /dev-python/botocore
parentdev-python/google-auth: Bump to 1.28.0 (diff)
downloadgentoo-e4f97611326f8dd7fcab41e1feddedd25e8d6644.tar.gz
gentoo-e4f97611326f8dd7fcab41e1feddedd25e8d6644.tar.bz2
gentoo-e4f97611326f8dd7fcab41e1feddedd25e8d6644.zip
dev-python/botocore: Bump to 1.20.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.29.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5c5b3019d50d..1b3b6c8414f6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,4 +12,5 @@ DIST botocore-1.20.25.tar.gz 7508526 BLAKE2B 244b578cc0596e4fc6b225cd29d0b5ca2e4
DIST botocore-1.20.26.tar.gz 7510615 BLAKE2B bc8716642c09ec74f7d057bcd9608cbbad98fcb4caf09e0684a03744fda81c0483aebaa4c85e416dac7d54d0f2804aba59f15e714211b59edd824cd3067ed412 SHA512 30ce061c1b7e1830caaf7382352180f9316f8d1d806269726ef3bc00eeb7a3fc7689e43eb4666fe700ca2de564b427c4916289a555aca0138a630059462216c9
DIST botocore-1.20.27.tar.gz 7518860 BLAKE2B 73a5a5302a0adfe9c72ec40f0edec8fc97f9dcec0428f5785f2546d50e4b8eb8a9c287b29218ebd8ebe091ef0fd022a5b0ba459aae435c363511484a936d2ffb SHA512 1b63295a2f6cdf2c06cc10cd35c350a07eb5326bbd42f2dc2084bb54cac3ebb40f0635180e227632184a6bbff3b58b67bd90878acbfa4cc61879b7b8e77f3fbc
DIST botocore-1.20.28.tar.gz 7526082 BLAKE2B 523db8ca7ff9ae87ad30fe539f20b34f4627b3a60f58635778d81b7ab055ac7cfbe04b4c4ca6508284dd37f2e6b953210ed2def9608026490332d200f306f7a9 SHA512 f3af2bd784b96a2778361a83d0ad61e5108b0a90b3756575bc4b93aaddb13a0a07e6589f582f03ca95252b272e1f84c350c5a2e1f342f98627f70e8f42350c18
+DIST botocore-1.20.29.tar.gz 7533728 BLAKE2B 75ca3262805177118d0f1a6060d98badf54b07f3b607c4c1c0d057045f671474b11493819030a9e65080af0cdd48c8ea686836b7c9ef7bfe6098babf260f221d SHA512 92d3887929b34e5e6a80b1330e00e6a72d8cfd96b81cc36eed969361db4756607c7c447af73b05f5ff0c27699e32636df12627693c667dea0a9955d2553ea35e
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.29.ebuild b/dev-python/botocore/botocore-1.20.29.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.29.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}