summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-18 10:59:15 +0000
committerSam James <sam@gentoo.org>2021-11-18 10:59:15 +0000
commitfffa0d2a8dc7a25c52fd1f786efbb1e702b07167 (patch)
tree1fe29b61467a8c62caec9b26b67614e82bda53bc /dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
parentdev-python/pandas: try avoid scipy dependency on HPPA (diff)
downloadgentoo-fffa0d2a8dc7a25c52fd1f786efbb1e702b07167.tar.gz
gentoo-fffa0d2a8dc7a25c52fd1f786efbb1e702b07167.tar.bz2
gentoo-fffa0d2a8dc7a25c52fd1f786efbb1e702b07167.zip
dev-python/bottleneck: no longer depends on scipy
The dependency was dropped upstream a bit ago. Bug: https://bugs.gentoo.org/804115 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild')
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild b/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..944a15992cfd
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast NumPy array functions written in Cython"
+HOMEPAGE="https://pypi.org/project/Bottleneck/"
+SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" ./tools/test-installed-bottleneck.py -vv -m full || die
+}