summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-19 22:48:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-19 22:49:56 +0200
commitfc4b41806845522db7ca547d902359f5e8232f24 (patch)
tree5daf316abe8152f79e4ce270cb2c1d3a30c254b6 /dev-python/bottleneck
parentfcaps.eclass: support EAPI 8 (diff)
downloadgentoo-fc4b41806845522db7ca547d902359f5e8232f24.tar.gz
gentoo-fc4b41806845522db7ca547d902359f5e8232f24.tar.bz2
gentoo-fc4b41806845522db7ca547d902359f5e8232f24.zip
dev-python/bottleneck: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bottleneck')
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.2.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/bottleneck/bottleneck-1.3.2.ebuild b/dev-python/bottleneck/bottleneck-1.3.2.ebuild
index b45dcc831d44..ed1fd761efa2 100644
--- a/dev-python/bottleneck/bottleneck-1.3.2.ebuild
+++ b/dev-python/bottleneck/bottleneck-1.3.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -13,17 +13,15 @@ SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
SLOT="0"
LICENSE="BSD"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose )"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
python_test() {
- ${EPYTHON} ./tools/test-installed-bottleneck.py
+ "${EPYTHON}" ./tools/test-installed-bottleneck.py -vv -m full || die
}