summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 22:01:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:06 +0200
commit094fb16a51d442ac0285e19360218757927be029 (patch)
tree8a470ef47e311c4f81d4d029eb47a2b4c493a3d1 /dev-python/breathe/breathe-4.31.0.ebuild
parentx11-misc/synergy: Bump to 1.14.1.32 (diff)
downloadgentoo-094fb16a51d442ac0285e19360218757927be029.tar.gz
gentoo-094fb16a51d442ac0285e19360218757927be029.tar.bz2
gentoo-094fb16a51d442ac0285e19360218757927be029.zip
dev-python/breathe: Bump to 4.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/breathe/breathe-4.31.0.ebuild')
-rw-r--r--dev-python/breathe/breathe-4.31.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/breathe/breathe-4.31.0.ebuild b/dev-python/breathe/breathe-4.31.0.ebuild
new file mode 100644
index 000000000000..b0fbc7e01e85
--- /dev/null
+++ b/dev-python/breathe/breathe-4.31.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="
+ https://breathe.readthedocs.io/en/latest/
+ https://github.com/michaeljones/breathe/"
+SRC_URI="https://github.com/michaeljones/breathe/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ app-doc/doxygen
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-3.0.0[${PYTHON_USEDEP}]
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+"
+
+distutils_enable_tests pytest