summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-06-07 13:06:52 -0500
committerMichał Górny <mgorny@gentoo.org>2018-06-24 16:55:26 +0200
commit413d2406cb7ed7ce1171d8692a9cd2c7a5b6b1df (patch)
tree2e9ed0c737ffc89e8af8eca02d1a1fd501844c8e /dev-python/brotlipy/brotlipy-0.7.0.ebuild
parentdev-python/scandir: stable for all arches using the ALLARCHES policy. (diff)
downloadgentoo-413d2406cb7ed7ce1171d8692a9cd2c7a5b6b1df.tar.gz
gentoo-413d2406cb7ed7ce1171d8692a9cd2c7a5b6b1df.tar.bz2
gentoo-413d2406cb7ed7ce1171d8692a9cd2c7a5b6b1df.zip
dev-python/brotlipy: Introducing the package
Introduce the dev/python/brotlipy package into Gentoo. Closes: https://bugs.gentoo.org/654854 Closes: https://github.com/gentoo/gentoo/pull/8261 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/brotlipy/brotlipy-0.7.0.ebuild')
-rw-r--r--dev-python/brotlipy/brotlipy-0.7.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/brotlipy/brotlipy-0.7.0.ebuild b/dev-python/brotlipy/brotlipy-0.7.0.ebuild
new file mode 100644
index 000000000000..8d08a0abeedf
--- /dev/null
+++ b/dev-python/brotlipy/brotlipy-0.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+# Commit of the Brotli library bundled within brotlipy.
+BROTLI_BUNDLED_COMMIT="46c1a881b41bb638c76247558aa04b1591af3aa7"
+
+DESCRIPTION="Python binding to the Brotli library"
+HOMEPAGE="https://github.com/python-hyper/brotlipy/ https://pypi.python.org/pypi/brotlipy"
+SRC_URI="
+ https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/google/brotli/archive/${BROTLI_BUNDLED_COMMIT}.tar.gz -> brotli-${BROTLI_BUNDLED_COMMIT}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # Inject the brotli lib.
+ rm -r "${WORKDIR}/${P}/libbrotli" || die "Could not remove the bundled brotli lib folder."
+ cp -r "${WORKDIR}/brotli-${BROTLI_BUNDLED_COMMIT}/" "${WORKDIR}/${P}/libbrotli" || die "Could not inject the brotli lib."
+
+ # Tests fail if we have this folder preserved within the lib.
+ rm -r "${WORKDIR}/${P}/libbrotli/python" || die "Could not remove 'python' subfolder."
+
+ eapply_user
+}
+
+python_test() {
+ py.test -v || die "Testing failed"
+}