summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2021-05-17 09:48:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2021-05-17 09:48:25 +0200
commit201e942992df54f0818e047b194399cd5dbd8e67 (patch)
tree0084c10b6e8e6ca161162e146ffa7ea50ed94a21 /dev-python/brython
parentgames-board/stockfish: amd64 stable wrt bug #790623 (diff)
downloadgentoo-201e942992df54f0818e047b194399cd5dbd8e67.tar.gz
gentoo-201e942992df54f0818e047b194399cd5dbd8e67.tar.bz2
gentoo-201e942992df54f0818e047b194399cd5dbd8e67.zip
dev-python/brython: add 3.9.0
Closes: https://bugs.gentoo.org/790632 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/brython')
-rw-r--r--dev-python/brython/Manifest1
-rw-r--r--dev-python/brython/brython-3.9.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/brython/Manifest b/dev-python/brython/Manifest
index 1f41f7bbb216..a01b0910bcd3 100644
--- a/dev-python/brython/Manifest
+++ b/dev-python/brython/Manifest
@@ -1,2 +1,3 @@
DIST brython-3.7.3.tar.gz 10403156 BLAKE2B a30c957925149f1b7eb736c1fcacd171dffb5846f6a343227596e759820c794c265befbb04137e797c1eabe8d9f0a3faa93fe425e4b0c13fda4c78b4c4bb1ecd SHA512 f234c7bc67d935e5bd5bfa8e473bccf90245ab4dabccd363bc5e9e01e1c9ea9d95989c5f8b323c158e286ac4a66106eb07722d1fcc82353ad036e35b4fda5669
DIST brython-3.7.4.tar.gz 10473351 BLAKE2B c457498d7f9b61ef416d6ec0ccbf86e3fdc7cc55f90fd8a853005285cab814d054319a5437cc24d22d6088af6f5b58da5311c6f68721d7b243fe31ef450c38a1 SHA512 70959debdd0a3e7f7e533f17aa2149802454bee23598d844156756ee6aab697b75337a26a341e6408966036f419696d0f8b073cb5383f32a9f6de65cde2fa40a
+DIST brython-3.9.0.tar.gz 10232037 BLAKE2B 4dc70efa14174f90cddd72ba9c07afd7be4fc81cde3f9ace7b5f015acd4cc18e9ab222aded496523f7298cb7ecb93c1d691fda818ef9fe15fabbb876143af487 SHA512 fcacc6f5e959afd2c84980eb0a650028ad018f4ebda05c53ef0a73ef5a8e1b4a28b2940c08f6b5e82bb52975b671610ad47e42de0d6d3030a6b9f5af02784c20
diff --git a/dev-python/brython/brython-3.9.0.ebuild b/dev-python/brython/brython-3.9.0.ebuild
new file mode 100644
index 000000000000..864d481de5dd
--- /dev/null
+++ b/dev-python/brython/brython-3.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit webapp python-single-r1
+
+DESCRIPTION="A Python 3 implementation for client-side web programming"
+HOMEPAGE="http://www.brython.info"
+SRC_URI="https://github.com/${PN}-dev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ dodoc LICENCE.txt README.md
+ rm -v LICENCE.txt README.md bower.json .{git*,tra*} server.py || die
+
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_src_install
+}