summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:28 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:28 +0100
commit6b98fe08dd71c70247fbc207dbca8bd7f69d0e7c (patch)
tree7b173903cb054fbe6eaeb1efc81cb185959909bf /dev-python/bsddb3
parentdev-python/billiard: Remove old (diff)
downloadgentoo-6b98fe08dd71c70247fbc207dbca8bd7f69d0e7c.tar.gz
gentoo-6b98fe08dd71c70247fbc207dbca8bd7f69d0e7c.tar.bz2
gentoo-6b98fe08dd71c70247fbc207dbca8bd7f69d0e7c.zip
dev-python/bsddb3: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/Manifest1
-rw-r--r--dev-python/bsddb3/bsddb3-6.1.1.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/bsddb3/Manifest b/dev-python/bsddb3/Manifest
index 1bb6116f6cf2..fbbd378d34af 100644
--- a/dev-python/bsddb3/Manifest
+++ b/dev-python/bsddb3/Manifest
@@ -1,2 +1 @@
-DIST bsddb3-6.1.1.tar.gz 450571 BLAKE2B fae21052d3422e6e837f21a0e5f65aac063cb4c03b4c833e8b74fdd7da929972f81c3eaf5e869ce0990c1d55454d9f5964c3d526a44c047124d12da2afd78361 SHA512 f5e95edf2d18f04f4a306450a67ad675902b102cde9fdebd870727c2649ba7dd759206708c9225af871e0811e17812ef46c90ea6854eb3209ba36c86900ffb01
DIST bsddb3-6.2.4.tar.gz 242397 BLAKE2B b6b9c6d4d3231bce400ae46a5df85abddd83bfd3e4e52d0192c2c91faab51af14946c9a8682f55ff8251fd0d1f7a00ba834d7a39c1574b4adcfe2ea396cf684d SHA512 15bb714242b05649a7c40ccd153979e596340ef039c89549b215fc5438a12fedb44150195063d2783c6c06ede3552506e31e8013b6b0431d27dd7e14975c08b0
diff --git a/dev-python/bsddb3/bsddb3-6.1.1.ebuild b/dev-python/bsddb3/bsddb3-6.1.1.ebuild
deleted file mode 100644
index 2fabdb1ad52a..000000000000
--- a/dev-python/bsddb3/bsddb3-6.1.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_5 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit db-use distutils-r1 multilib
-
-DESCRIPTION="Python bindings for Berkeley DB"
-HOMEPAGE="https://www.jcea.es/programacion/pybsddb.htm https://pypi.org/project/bsddb3/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="
- >=sys-libs/db-4.7:=
- <sys-libs/db-6.2:=
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_prepare() {
- # This list should be kept in sync with setup.py.
- if [[ -z ${DB_VER} ]]; then
- for DB_VER in 6.1 6.0 5.3 5.2 5.1 5.0 4.8 4.7; do
- has_version "sys-libs/db:${DB_VER}" && break
- done
- fi
-
- # Force version.
- sed -e "s/db_ver = None/db_ver = (${DB_VER%.*}, ${DB_VER#*.})/" \
- -e "s/dblib = 'db'/dblib = '$(db_libname ${DB_VER})'/" \
- -i setup2.py setup3.py || die
-
- # Adjust test.py to look in build/lib.
- sed -e "s/'lib.%s' % PLAT_SPEC/'lib'/" \
- -i test2.py test3.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- # These are needed for both build and install.
- export BERKELEYDB_DIR="${EPREFIX}/usr"
- export BERKELEYDB_INCDIR="$(db_includedir ${DB_VER})"
- export BERKELEYDB_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export YES_I_HAVE_THE_RIGHT_TO_USE_THIS_BERKELEY_DB_VERSION=1
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- if python_is_python3; then
- PYTHONPATH=Lib3 "${PYTHON}" test3.py -v || die "Testing failed with ${EPYTHON}"
- else
- PYTHONPATH=Lib "${PYTHON}" test.py -v || die "Testing failed with ${EPYTHON}"
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/html/. )
- distutils-r1_python_install_all
-}