summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 09:53:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 10:10:44 +0200
commitf203e85909159b316463b1bfd205c3c02c5b2860 (patch)
tree976994b891798451e3c3b1db1a0e0c3d61708898 /dev-python/cachetools
parentdev-python/cachetools: Port to py3.9 (diff)
downloadgentoo-f203e85909159b316463b1bfd205c3c02c5b2860.tar.gz
gentoo-f203e85909159b316463b1bfd205c3c02c5b2860.tar.bz2
gentoo-f203e85909159b316463b1bfd205c3c02c5b2860.zip
dev-python/cachetools: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cachetools')
-rw-r--r--dev-python/cachetools/Manifest1
-rw-r--r--dev-python/cachetools/cachetools-4.1.1.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/cachetools/Manifest b/dev-python/cachetools/Manifest
index 5f7c0006fdd1..dbf954a574ed 100644
--- a/dev-python/cachetools/Manifest
+++ b/dev-python/cachetools/Manifest
@@ -1 +1,2 @@
DIST cachetools-3.1.1.tar.gz 22055 BLAKE2B 9141adb9cff5e7f76a370666c24664de09b1562a9e40636b8103157cc65b146dca96ad871065191618e2d458078cb7da30c80da21b4fded73097bda7916f4819 SHA512 23a7d9c91f97727984585745169dbf94922288e464196d5c05f442226cbff4efeb3588ed463f481bd75892824188bd3ab8031f4f2f8e52924c74428b1034714a
+DIST cachetools-4.1.1.tar.gz 23574 BLAKE2B 5777d243ae87635766811fd2aea8789f9f1674ae3a7ddcc08bb3c8d4345002d65cdbd00cbaf75ba801dccffb1896a75688a6e97f984e1d498a93726854398196 SHA512 254e8821feaaf4fff656aa2beaf0b2c1c6dbe8698148be783bb18a6476f758061471906e4774f47bd8722dbbbc09745088a8f61eb5c455fbe85ef17a3816ce7d
diff --git a/dev-python/cachetools/cachetools-4.1.1.ebuild b/dev-python/cachetools/cachetools-4.1.1.ebuild
new file mode 100644
index 000000000000..9e0614ce3fcb
--- /dev/null
+++ b/dev-python/cachetools/cachetools-4.1.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible memoizing collections and decorators"
+HOMEPAGE="https://pypi.org/project/cachetools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+distutils_enable_tests pytest