summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-12 08:22:00 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-12 08:22:00 -0400
commite63f58c5a398fd895db3cd3ac36915f92c25a636 (patch)
treeea1bf314c81c4c715b5b8f45d31bc6c898b98310 /dev-python/cairocffi/cairocffi-0.8.0.ebuild
parentdev-python/xcffib: version bump to 0.5.1 (diff)
downloadgentoo-e63f58c5a398fd895db3cd3ac36915f92c25a636.tar.gz
gentoo-e63f58c5a398fd895db3cd3ac36915f92c25a636.tar.bz2
gentoo-e63f58c5a398fd895db3cd3ac36915f92c25a636.zip
dev-python/cairocffi: version bump to 0.8.0
Diffstat (limited to 'dev-python/cairocffi/cairocffi-0.8.0.ebuild')
-rw-r--r--dev-python/cairocffi/cairocffi-0.8.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cairocffi/cairocffi-0.8.0.ebuild b/dev-python/cairocffi/cairocffi-0.8.0.ebuild
new file mode 100644
index 000000000000..387732cd5b69
--- /dev/null
+++ b/dev-python/cairocffi/cairocffi-0.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1 virtualx
+
+MY_PN="${PN}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="CFFI-based drop-in replacement for Pycairo"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/SimonSapin/cairocffi"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ x11-libs/cairo:0=
+ x11-libs/gdk-pixbuf[jpeg]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )"
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ virtx py.test -v --pyargs cairocffi || die "testsuite failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}