summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-09-04 21:29:42 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-09-04 21:29:42 +0900
commit7b9489a6d3a54a3ee3e20d7b0d8cbb458da1872f (patch)
treea44226ad4ddd6c22134e127ee4d45d4382c29b6f /dev-python/cangjie
parentapp-i18n/libcangjie: update to EAPI 6 (diff)
downloadgentoo-7b9489a6d3a54a3ee3e20d7b0d8cbb458da1872f.tar.gz
gentoo-7b9489a6d3a54a3ee3e20d7b0d8cbb458da1872f.tar.bz2
gentoo-7b9489a6d3a54a3ee3e20d7b0d8cbb458da1872f.zip
dev-python/cangjie: tidy
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/cangjie')
-rw-r--r--dev-python/cangjie/cangjie-1.2-r1.ebuild28
-rw-r--r--dev-python/cangjie/metadata.xml14
2 files changed, 19 insertions, 23 deletions
diff --git a/dev-python/cangjie/cangjie-1.2-r1.ebuild b/dev-python/cangjie/cangjie-1.2-r1.ebuild
index d3daf09ed18c..2c974fae5dd8 100644
--- a/dev-python/cangjie/cangjie-1.2-r1.ebuild
+++ b/dev-python/cangjie/cangjie-1.2-r1.ebuild
@@ -1,15 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
+EAPI="6"
PYTHON_COMPAT=( python{3_4,3_5,3_6} )
inherit autotools python-r1
-DESCRIPTION="The Python bindings to libcangjie"
-HOMEPAGE="http://cangjians.github.io"
-SRC_URI="https://github.com/Cangjians/pycangjie/releases/download/v${PV}/cangjie-${PV}.tar.xz"
+DESCRIPTION="Python wrapper for libcangjie"
+HOMEPAGE="http://cangjians.github.io/"
+SRC_URI="https://github.com/Cangjians/py${PN}/releases/download/v${PV}/${P#py}.tar.xz"
LICENSE="LGPL-3+"
SLOT="0"
@@ -17,15 +16,13 @@ KEYWORDS="amd64 x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="
- app-i18n/libcangjie
- ${PYTHON_DEPS}"
-DEPEND="
- ${RDEPEND}
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/libcangjie"
+DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-cython-022.patch" )
+PATCHES=( "${FILESDIR}"/${P}-cython-022.patch )
src_prepare() {
default
@@ -33,10 +30,10 @@ src_prepare() {
}
src_configure() {
- myeconf() {
- ECONF_SOURCE="${S}" econf PYTHON="${PYTHON}"
+ python_configure() {
+ ECONF_SOURCE="${S}" econf
}
- python_foreach_impl run_in_build_dir myeconf
+ python_foreach_impl run_in_build_dir python_configure
}
src_compile() {
@@ -51,6 +48,5 @@ src_install() {
python_foreach_impl run_in_build_dir default
einstalldocs
- # package only installs python modules
find "${D}" -name '*.la' -delete || die
}
diff --git a/dev-python/cangjie/metadata.xml b/dev-python/cangjie/metadata.xml
index f725cd5af33c..5249303a03c1 100644
--- a/dev-python/cangjie/metadata.xml
+++ b/dev-python/cangjie/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
- <upstream>
- <remote-id type="github">Cangjians/pycangjie</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Cangjians/pycangjie</remote-id>
+ </upstream>
</pkgmetadata>