summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:04 +0200
commitffae12ec888d9b8e05121226d456d80289ad584d (patch)
tree55aed1032607661d2439bc54a85ddf667117a91b /dev-python/catkin_pkg
parentdev-python/cachetools: Remove redundant versions (diff)
downloadgentoo-ffae12ec888d9b8e05121226d456d80289ad584d.tar.gz
gentoo-ffae12ec888d9b8e05121226d456d80289ad584d.tar.bz2
gentoo-ffae12ec888d9b8e05121226d456d80289ad584d.zip
dev-python/catkin_pkg: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/catkin_pkg')
-rw-r--r--dev-python/catkin_pkg/Manifest1
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/catkin_pkg/Manifest b/dev-python/catkin_pkg/Manifest
index 671b5b7ce15b..68b644507c31 100644
--- a/dev-python/catkin_pkg/Manifest
+++ b/dev-python/catkin_pkg/Manifest
@@ -1,2 +1 @@
-DIST catkin_pkg-0.4.20-gh.tar.gz 64039 BLAKE2B f57de3000798c0f65f4a759f605d80161d598bf648b556b37a66d31366bb3d56805c4178badcfff5e0286e8ed07f1699a2b6eb36112a51abb4d540928a108ba8 SHA512 7b2b25186b9fefd3acd11b785562c6481e9f37f568d66a674d314318686d3e0d2e8ce0cacab126411de78c71e2b8f378439d442d3fd041b3e92a25e95cef4e19
DIST catkin_pkg-0.4.22-gh.tar.gz 64407 BLAKE2B cbcc9b766b8fcde05a89b41d6797c02e12b65ee4518b37e31d120aa2cc43d5b7d588ca668ae0bbe2a2b10ae2883aaf8e3414449292af7ea8ba01d05e649e402e SHA512 e7119dde7fc70503d8b8cedf505d93aef719039a836186738d017500f8d53cbd73ae4f017cb8d86cc007978066e6471b971039387a07e2eb3c6894569a30946b
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild
deleted file mode 100644
index 53b5bb90f674..000000000000
--- a/dev-python/catkin_pkg/catkin_pkg-0.4.20.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7,3_8} pypy3 )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the catkin package system"
-HOMEPAGE="https://wiki.ros.org/catkin_pkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND} ${BDEPEND}
- test? (
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-RDEPEND="${RDEPEND}
- !<dev-util/catkin-0.7.14"
-PATCHES=(
- "${FILESDIR}/catkin_prefix2.patch"
- "${FILESDIR}/ros_packages.patch"
- "${FILESDIR}/infinite_loop4.patch"
-)
-
-python_test() {
- nosetests -s --tests test || die
-}