summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/celementtree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/celementtree')
-rw-r--r--dev-python/celementtree/Manifest1
-rw-r--r--dev-python/celementtree/celementtree-1.0.5-r2.ebuild45
-rw-r--r--dev-python/celementtree/files/celementtree-1.0.5-setuptools.patch12
-rw-r--r--dev-python/celementtree/files/celementtree-1.0.5-use_system_expat.patch44
-rw-r--r--dev-python/celementtree/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/celementtree/Manifest b/dev-python/celementtree/Manifest
new file mode 100644
index 000000000000..b7f490293739
--- /dev/null
+++ b/dev-python/celementtree/Manifest
@@ -0,0 +1 @@
+DIST cElementTree-1.0.5-20051216.tar.gz 93766 SHA256 b2e528c99837124b32598bde7a19da579203c600d71f22f4c84da0933ba09751 SHA512 2cb99e4980580f186eb9b8740bc5a3e6e85e714a5d1f613850a8f12f7dbc125c8aa7770f7fe70480fb96999212c11181ab681822c74429882c1dfe91c20e2af9 WHIRLPOOL 2788c2eb7ab7bb3a654b535d273cb198eaf15d2265b00e4a9da3b1aa097041db34ce3ebd7b393e75a806957dca3b5c712e5256bc69f0eceb0c11c99bdb9bbce2
diff --git a/dev-python/celementtree/celementtree-1.0.5-r2.ebuild b/dev-python/celementtree/celementtree-1.0.5-r2.ebuild
new file mode 100644
index 000000000000..abdfd29fde30
--- /dev/null
+++ b/dev-python/celementtree/celementtree-1.0.5-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="cElementTree-${PV}-20051216"
+
+DESCRIPTION="The cElementTree module is a C implementation of the ElementTree API"
+HOMEPAGE="http://effbot.org/zone/celementtree.htm http://pypi.python.org/pypi/cElementTree"
+SRC_URI="http://effbot.org/downloads/${MY_P}.tar.gz"
+
+LICENSE="ElementTree"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="examples"
+
+RDEPEND=">=dev-python/elementtree-1.2[${PYTHON_USEDEP}]
+ >=dev-libs/expat-1.95.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-use_system_expat.patch"
+ "${FILESDIR}/${P}-setuptools.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. selftest.py )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/celementtree/files/celementtree-1.0.5-setuptools.patch b/dev-python/celementtree/files/celementtree-1.0.5-setuptools.patch
new file mode 100644
index 000000000000..d70dfab1a519
--- /dev/null
+++ b/dev-python/celementtree/files/celementtree-1.0.5-setuptools.patch
@@ -0,0 +1,12 @@
+--- setup.py.orig 2007-07-04 23:05:19.000000000 -0700
++++ setup.py 2007-07-04 23:05:58.000000000 -0700
+@@ -6,7 +6,8 @@
+ # Usage: python setup.py install
+ #
+
+-from distutils.core import setup, Extension
++from setuptools import setup
++from distutils.core import Extension
+ from distutils import sysconfig
+ import sys, os
+
diff --git a/dev-python/celementtree/files/celementtree-1.0.5-use_system_expat.patch b/dev-python/celementtree/files/celementtree-1.0.5-use_system_expat.patch
new file mode 100644
index 000000000000..fb90e59a4492
--- /dev/null
+++ b/dev-python/celementtree/files/celementtree-1.0.5-use_system_expat.patch
@@ -0,0 +1,44 @@
+diff -u a/selftest.py b/selftest.py
+--- a/selftest.py 2005-12-16 23:57:47.000000000 +0200
++++ b/selftest.py 2007-07-03 08:07:45.000000000 +0300
+@@ -176,8 +176,6 @@
+ </ns0:root>
+
+ >>> parser = ElementTree.XMLParser()
+- >>> parser.version
+- 'Expat 1.95.8'
+ >>> parser.feed(open("samples/simple.xml").read())
+ >>> print serialize(parser.close())
+ <root>
+diff -u a/setup.py b/setup.py
+--- a/setup.py 2005-12-16 23:57:47.000000000 +0200
++++ b/setup.py 2007-07-03 08:00:57.000000000 +0300
+@@ -23,16 +23,6 @@
+ # --------------------------------------------------------------------
+ # expat library
+
+-sources = [
+- "expat/xmlparse.c",
+- "expat/xmlrole.c",
+- "expat/xmltok.c",
+- ]
+-
+-includes = [
+- "expat",
+- ]
+-
+ defines = [
+ ("XML_STATIC", None),
+ ]
+@@ -63,9 +53,9 @@
+
+ ext_modules.append(
+ Extension(
+- "cElementTree", ["cElementTree.c"] + sources,
++ "cElementTree", ["cElementTree.c"],
+ define_macros=defines,
+- include_dirs=includes,
++ libraries=['expat'],
+ )
+ )
+
diff --git a/dev-python/celementtree/metadata.xml b/dev-python/celementtree/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/celementtree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>