summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 22:38:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 22:41:02 +0200
commit0bcbbcb192f41ccffc5bfafb2e3141a010547393 (patch)
treeef4d708492cad8b43eca4a6176a766dc34b565bb /dev-python/certifi
parentdev-python/cliff: Remove old (diff)
downloadgentoo-0bcbbcb192f41ccffc5bfafb2e3141a010547393.tar.gz
gentoo-0bcbbcb192f41ccffc5bfafb2e3141a010547393.tar.bz2
gentoo-0bcbbcb192f41ccffc5bfafb2e3141a010547393.zip
dev-python/certifi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/Manifest1
-rw-r--r--dev-python/certifi/certifi-2020.4.5.1.ebuild43
-rw-r--r--dev-python/certifi/files/certifi-2020.4.5.1-use-system-cacerts.patch30
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/certifi/Manifest b/dev-python/certifi/Manifest
index 29e2111ba5ba..283e3260e864 100644
--- a/dev-python/certifi/Manifest
+++ b/dev-python/certifi/Manifest
@@ -1,2 +1 @@
-DIST certifi-2020.4.5.1.tar.gz 158038 BLAKE2B 988b29097b869b43095363b6ca344e3ce6c895f699b9d8b2576cb7108c5e12ea8a485c5f1dbc3d304d4243bdb09bce231fae15eb6abe47eee30afc1dc4ab4075 SHA512 8b0312aba427c29f6ebaf8140493f9673043e3f76f9bb1002a8fbc7a943303effad15173805e276147548d0978630655763b9ea60410135ba08f413fa77a5738
DIST certifi-shim-9999.tar.gz 3762 BLAKE2B 3ea85314e37a989d4894ea5fc89fb138e06c7912277f90466c6edb121c39f33b031bcc08346c4766c99fb193a2d53801aa1e8ef30cfede9a7e8247c7e443faef SHA512 ca2844f1680a019dbb5a440141d8ebaddd7c78ce47a23a48a50d2d857d012f90d74d4200168964787e31f16b1e9d7c981c033ff99f1e3ea1fa73cbbbf255edbd
diff --git a/dev-python/certifi/certifi-2020.4.5.1.ebuild b/dev-python/certifi/certifi-2020.4.5.1.ebuild
deleted file mode 100644
index 35515f2569a1..000000000000
--- a/dev-python/certifi/certifi-2020.4.5.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1 prefix readme.gentoo-r1
-
-DESCRIPTION="Python package for providing Mozilla's CA Bundle"
-HOMEPAGE="https://certifi.io/ https://pypi.org/project/certifi"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="app-misc/ca-certificates"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# Do not drop this patch -- this will affect system's security
-PATCHES=( "${FILESDIR}"/${PN}-2020.4.5.1-use-system-cacerts.patch )
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Precaution -- nothing should use bundled CA certificates
- rm certifi/cacert.pem || die "Failed to delete bundled CA certificates"
-
- eprefixify certifi/core.py
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local DOC_CONTENTS="
- In Gentoo, we don't use certifi's bundled CA certificates.
- Instead we remove bundled cacert.pem and patch certifi
- to return system's CA certificates.
- "
- readme.gentoo_create_doc
-}
diff --git a/dev-python/certifi/files/certifi-2020.4.5.1-use-system-cacerts.patch b/dev-python/certifi/files/certifi-2020.4.5.1-use-system-cacerts.patch
deleted file mode 100644
index 692439a10eac..000000000000
--- a/dev-python/certifi/files/certifi-2020.4.5.1-use-system-cacerts.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From f07497e36ccc883626ae5cdfa7f81fcb3fc0d549 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sun, 5 Apr 2020 23:43:30 +0200
-Subject: [PATCH] Use system's CA certificate store
-
----
- certifi/core.py | 7 +++----
- 1 file changed, 3 insertions(+), 4 deletions(-)
-
-diff --git a/certifi/core.py b/certifi/core.py
-index 56b52a3..467880f 100644
---- a/certifi/core.py
-+++ b/certifi/core.py
-@@ -21,10 +21,9 @@ except ImportError:
-
-
- def where():
-- f = os.path.dirname(__file__)
--
-- return os.path.join(f, "cacert.pem")
-+ return "@GENTOO_PORTAGE_EPREFIX@/etc/ssl/certs/ca-certificates.crt"
-
-
- def contents():
-- return read_text("certifi", "cacert.pem", encoding="ascii")
-+ with open(where(), "r", encoding="ascii") as f:
-+ return f.read()
---
-2.24.1
-