summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 17:10:48 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 17:10:48 +0100
commite674ac4eb4457ebbf32eb5824f7745487903a3f9 (patch)
tree09f828ff44167748eaa1e8414e4fce09cd94c51a /dev-python/cftime
parentsci-libs/netcdf: Bump to 4.7.4 (diff)
downloadgentoo-e674ac4eb4457ebbf32eb5824f7745487903a3f9.tar.gz
gentoo-e674ac4eb4457ebbf32eb5824f7745487903a3f9.tar.bz2
gentoo-e674ac4eb4457ebbf32eb5824f7745487903a3f9.zip
dev-python/cftime: Time-handling functionality from netcdf4-python
Closes: https://bugs.gentoo.org/681744 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/cftime')
-rw-r--r--dev-python/cftime/Manifest1
-rw-r--r--dev-python/cftime/cftime-1.3.0.ebuild29
-rw-r--r--dev-python/cftime/metadata.xml12
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cftime/Manifest b/dev-python/cftime/Manifest
new file mode 100644
index 000000000000..2a651f051b41
--- /dev/null
+++ b/dev-python/cftime/Manifest
@@ -0,0 +1 @@
+DIST cftime-1.3.0.tar.gz 55668 BLAKE2B c233a3d45305476f422ca93f89348b7b3c018b10c0fa42d6649001b7bcdb4d26d230322108def41818449ec78dc531261b52d09252306fb5889ac4011af33828 SHA512 07f79e902142e8a314c9d09af08ea752454e490c3027ee44853f78c725305bf11cad90bd331edd204defded11e7f29173df9bef70ab805a28b745cc0afdd4685
diff --git a/dev-python/cftime/cftime-1.3.0.ebuild b/dev-python/cftime/cftime-1.3.0.ebuild
new file mode 100644
index 000000000000..756f757775cb
--- /dev/null
+++ b/dev-python/cftime/cftime-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="https://pypi.org/project/cftime"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e "/--cov/d" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/cftime/metadata.xml b/dev-python/cftime/metadata.xml
new file mode 100644
index 000000000000..7772129ae7c6
--- /dev/null
+++ b/dev-python/cftime/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">cftime</remote-id>
+ <remote-id type="github">Unidata/cftime</remote-id>
+ </upstream>
+</pkgmetadata>