summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-16 08:56:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-16 10:18:50 +0200
commit766b417420e76eec160e3f92ec19c5d69d3922dc (patch)
treef5a2e03cd2bb61e1e34cb3851576f0dbf99b88fd /dev-python/characteristic
parentdev-python/xmlschema: Bump to 1.2.2 (diff)
downloadgentoo-766b417420e76eec160e3f92ec19c5d69d3922dc.tar.gz
gentoo-766b417420e76eec160e3f92ec19c5d69d3922dc.tar.bz2
gentoo-766b417420e76eec160e3f92ec19c5d69d3922dc.zip
dev-python/characteristic: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/characteristic')
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r3.ebuild7
1 files changed, 1 insertions, 6 deletions
diff --git a/dev-python/characteristic/characteristic-14.3.0-r3.ebuild b/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
index 3d93f1c7222d..2fe3077b4082 100644
--- a/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
+++ b/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -14,16 +14,11 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
distutils_enable_sphinx docs
python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
distutils-r1_python_prepare_all
}