summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-27 00:03:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-27 00:37:20 +0200
commit56fe83fa38b967376183ab62b7c4ecba9713bb7f (patch)
tree345db53a1a81632febabdbee1a4cc7356df8f3a1 /dev-python/chardet
parentdev-python/biplist: remove trailing whitespaces. (diff)
downloadgentoo-56fe83fa38b967376183ab62b7c4ecba9713bb7f.tar.gz
gentoo-56fe83fa38b967376183ab62b7c4ecba9713bb7f.tar.bz2
gentoo-56fe83fa38b967376183ab62b7c4ecba9713bb7f.zip
dev-python/chardet: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-3.0.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index 7769fe8ffda9..a0d0050db9ac 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1,2 +1,3 @@
DIST chardet-2.3.0.tar.gz 164346 SHA256 e53e38b3a4afe6d1132de62b7400a4ac363452dc5dfcf8d88e8e0cce663c68aa SHA512 d554c9b4564905a2b6c6971aaea2a812174d86b58137c6a2f9d54e2abd2395e6529968b2ce3ca2d97c717d2bd0bd80ab5b98cae9afac1a4add9ea305145030dd WHIRLPOOL af17bac2778a86d6fe9643a512a307cbcf92e4b43238b2d3d2bae53e646fccbdf40f31f41f9452e7d4f4c84d1ee637199af841a828d49f3452190749fee284c1
DIST chardet-3.0.2.tar.gz 1872630 SHA256 3b92afd82ddea09d30832fac141840d6569c34f27633e4ad273c66172246116f SHA512 9466e8bdd4d49ca51664fefa170e2887bebf17d017d49056a0efe9baef4dc58e2a9e0766d41c1fcb06254e1346021d1d86b1eb55d4b71a061da93ea830f1dfce WHIRLPOOL 4010a838619b3f04d1266bdee49e26169724f1c83c38a3a9cc081fc8f2166e46ecf9544bc25e276a7dec4af7a64f469a74aabc8ecdc745fd10d364db331ee704
+DIST chardet-3.0.3.tar.gz 1872668 SHA256 99cc5d0c13fb0ec02bc4c8a35b35ff698ba1ebdb6d065b53276f0d10d59c2cdc SHA512 7769d80178fb9ded7f04c32969da1a73938b04ffcc9d8de2e593135731e29fbf1e2c21e39ca92d3789e08c9a800f9ec0aafc3c1d12580f4f1efb82e697700264 WHIRLPOOL 9ab8951cdcc69cc05974e67c421a5524bbdf18c96a5f272502b4ae22583520cbc7a82eb499de67cc5aac846af9db1279bc27581f3ce0afd73de2ead861663268
diff --git a/dev-python/chardet/chardet-3.0.3.ebuild b/dev-python/chardet/chardet-3.0.3.ebuild
new file mode 100644
index 000000000000..b57346e262b8
--- /dev/null
+++ b/dev-python/chardet/chardet-3.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet https://pypi.python.org/pypi/chardet"
+SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# PyPI tarball is missing test.py: https://github.com/chardet/chardet/pull/118
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/disable-pytest-runner.patch
+)
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}