summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-10 21:02:19 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-10 22:22:15 +0100
commitb05d1f62c97fc744017f69c5ee7a0cf3f3fc3523 (patch)
tree9fe18a27c4165345be176b18f5ca70563266911d /dev-python/chardet
parentgames-arcade/cdogs-sdl: Remove -Werror for build (diff)
downloadgentoo-b05d1f62c97fc744017f69c5ee7a0cf3f3fc3523.tar.gz
gentoo-b05d1f62c97fc744017f69c5ee7a0cf3f3fc3523.tar.bz2
gentoo-b05d1f62c97fc744017f69c5ee7a0cf3f3fc3523.zip
dev-python/chardet: Bump to 4.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-4.0.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index ab52c6066e0e..1fa67aa0c09c 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1 +1,2 @@
DIST chardet-3.0.4.tar.gz 1872214 BLAKE2B b93e2d3e0b5a5c35affa5e3ee661323029f79837a1222d8f69db72911301d9490c9788d2effc577eeeb2a50334cc855afc4bdf4b8dbafb143fcc411d93b824a9 SHA512 b433ea0e15e200df968e6d61c671c42fbd77e519eb033035c4a5c241e1f98e1dfaea6747af632788507583b3ef85b00d510b3f6ef5cf58589ceca1b3a088b357
+DIST chardet-4.0.0.tar.gz 1923933 BLAKE2B 10dce34cbe6f01536a526931510ed625bc5062335e9419e24c9e48d5697ebbe70dcc54ffaa976ec153340cc74c3086627a3b1dd9e34be32c89a9a81e83fd70d0 SHA512 cb0e052fdd9fec251ebc6eb3f31ca95ece017f2bfa99122997f989286988058ed9688e49d00631c63d8e4e52da1050e23f02b28d0e739aee7302b24c8808370e
diff --git a/dev-python/chardet/chardet-4.0.0.ebuild b/dev-python/chardet/chardet-4.0.0.ebuild
new file mode 100644
index 000000000000..fbe6454adc15
--- /dev/null
+++ b/dev-python/chardet/chardet-4.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet https://pypi.org/project/chardet/"
+SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# PyPI tarball is missing test.py: https://github.com/chardet/chardet/pull/118
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+DEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-4.patch
+)
+
+distutils_enable_tests pytest