summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-10-26 00:37:05 +0200
committerZac Medico <zmedico@gentoo.org>2019-10-25 16:13:47 -0700
commit1608149401759e1f8bf3ca9efa876caae132a9c6 (patch)
tree0dcc0092e5513408d5c6d0960b6d4a92ba633848 /dev-python/cheroot
parentdev-python/s3transfer: add new version 0.2.1 (diff)
downloadgentoo-1608149401759e1f8bf3ca9efa876caae132a9c6.tar.gz
gentoo-1608149401759e1f8bf3ca9efa876caae132a9c6.tar.bz2
gentoo-1608149401759e1f8bf3ca9efa876caae132a9c6.zip
dev-python/cheroot: version bump
Closes: https://bugs.gentoo.org/679810 Closes: https://github.com/gentoo/gentoo/pull/13441 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/cheroot')
-rw-r--r--dev-python/cheroot/Manifest1
-rw-r--r--dev-python/cheroot/cheroot-8.2.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/cheroot/Manifest b/dev-python/cheroot/Manifest
index 83b02d2e41ff..71d038c979ab 100644
--- a/dev-python/cheroot/Manifest
+++ b/dev-python/cheroot/Manifest
@@ -1,2 +1,3 @@
DIST cheroot-6.0.0.tar.gz 62763 BLAKE2B 0946c01c6a6233dc60ca3dd896c3d1dbc0feb97d5099d88598db340a8812b2be4cb076383c0e39d30cd2c6fd3402e048b716a02e82bec8ce08d5b8fca4b1be0f SHA512 0109fbf3b73ed3f12261eaa3c6d86b6c6b80a1ba3564548ba3288aa6c61a1c08db60886e677991bf7997e6a5b1ec7767a3e06098ec1748453e72c40fda7b82a7
DIST cheroot-6.5.4.tar.gz 81067 BLAKE2B 5304373bb8c7cefa341260d4fdb8a99b9e22041260342a716a6b95ba324b4f31d20fb44d8dc10840fb35d3b04de1283deb9aca11bc78772655bf7ad81cf16f3c SHA512 62a48ced225bf9167259b82f5e88a953bdc422982a6c0b0121b28e895cc8347cc033f573b57a048c59167586e0b21e94ad233ce2b65a1b72feb01db82b5ed411
+DIST cheroot-8.2.1.tar.gz 89470 BLAKE2B 57515ecf6e047ea67599631a98c15307ea5f9929b398a8143bc157bfe71129b11a1f4bc841f586f98167ac4c6c9680d476bd167323e5828163b4bff9bf24c360 SHA512 3f6b55c6b2403569eedb1fe7b473d3a65ad5d06cb99a38370316db38b6138b1a6921c6b7d8ba64424c5b8c20c9c58ada33da7cb8ebb6f313610f63c1f364f862
diff --git a/dev-python/cheroot/cheroot-8.2.1.ebuild b/dev-python/cheroot/cheroot-8.2.1.ebuild
new file mode 100644
index 000000000000..bec1012424ea
--- /dev/null
+++ b/dev-python/cheroot/cheroot-8.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheroot is the high-performance, pure-Python HTTP server used by CherryPy."
+HOMEPAGE="https://cherrypy.org/ https://pypi.org/project/Cheroot/ https://github.com/cherrypy/cheroot"
+SRC_URI="mirror://pypi/C/${PN/c/C}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+# Unit tests are temporarily disabled for this version, see below for
+# what needs to be done.
+#IUSE="test"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/six-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-2.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]"
+
+ # Add the following for unit tests, some packages listed will need
+ # to be added and keyworded appropriately.
+# test? (
+# >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+# >=dev-python/pytest-mock-1.11.0[${PYTHON_USEDEP}]
+# >=dev-python/pytest-sugar-0.9.1[${PYTHON_USEDEP}]
+# >=dev-python/pytest-testmon-0.9.7[${PYTHON_USEDEP}]
+# ~dev-python/pytest-watch-4.2.0[${PYTHON_USEDEP}]
+# >=dev-python/pytest-xdist-1.2.28[${PYTHON_USEDEP}]
+# ~dev-python/coverage-4.5.3[${PYTHON_USEDEP}]
+# ~dev-python/codecov-2.0.15[${PYTHON_USEDEP}]
+# ~dev-python/pytest-cov-2.7.1[${PYTHON_USEDEP}]
+# >=dev-python/trustme-0.4.0[${PYTHON_USEDEP}]
+# dev-python/pyopenssl[${PYTHON_USEDEP}]
+# dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+# )"
+
+#python_test() {
+# py.test -v || die "tests failed under ${EPYTHON}"
+#}