summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-04 09:38:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-04 09:38:54 +0200
commitd8f8f0deae65eedcced8f55e3d2304f5c1c795fd (patch)
tree7f40337a8677294bc865acf1eb8334535674f4c1 /dev-python/cherrypy
parentdev-python/aesara: Remove old (diff)
downloadgentoo-d8f8f0deae65eedcced8f55e3d2304f5c1c795fd.tar.gz
gentoo-d8f8f0deae65eedcced8f55e3d2304f5c1c795fd.tar.bz2
gentoo-d8f8f0deae65eedcced8f55e3d2304f5c1c795fd.zip
dev-python/cherrypy: Bump to 18.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest1
-rw-r--r--dev-python/cherrypy/cherrypy-18.6.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index 6414d1c7d60a..f85a63b78c25 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1 +1,2 @@
DIST CherryPy-18.6.0.tar.gz 686804 BLAKE2B dae7f0ac403084acdf611e4a9e75f152355491e4383a1bd1374ae77ac68b415f41ce79f1e65a7a66c61aa0965ac94cd9bfd0d425cf7752ab54edf0bc0d8cabfb SHA512 cd33303fa9b9704ef427553091a6a6c2bbfea20e7d81acd2bcdc2855f8a36a084a0781bb19f3a084b24f0664bd7b318a667c8c79b5073381901acce4602de9d7
+DIST CherryPy-18.6.1.tar.gz 692730 BLAKE2B 44cef7ed54a090df396691001b794bf13be2c61003bf80b63223e3a42914ce50fcfe43c06626fb881105e3ed6fbf587df7024bbf7cfde00a8263c432f4cc7ae4 SHA512 186a0992a443e1ffc1a2924b3351dcb0e6cc6c88b39ac32330d6365fe1b0a35c2008a3a18e1a57f61ffd1901ea6134333bb6288024d8ffbb1fd8e8dcd3145007
diff --git a/dev-python/cherrypy/cherrypy-18.6.1.ebuild b/dev-python/cherrypy/cherrypy-18.6.1.ebuild
new file mode 100644
index 000000000000..f5d3a478fc2d
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-18.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="https://www.cherrypy.org/ https://pypi.org/project/CherryPy/"
+SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="ssl test"
+
+RDEPEND="
+ >=dev-python/cheroot-8.2.1[${PYTHON_USEDEP}]
+ >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/zc-lockfile[${PYTHON_USEDEP}]
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/routes[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/objgraph[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/pytest-services[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
+ -i setup.py || die
+
+ sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::g' \
+ -e 's:--cov[[:graph:]]+::g' \
+ -e 's:--doctest[[:graph:]]+::g' \
+ -i pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}