summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 23:07:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 23:14:23 +0200
commitee3effb64075b9888cc220ffeee477d9d67a9c3c (patch)
tree0029829f9825a80b345ffa32cfc1abb00c7ed442 /dev-python/cherrypy
parentdev-python/ws4py: Remove old (diff)
downloadgentoo-ee3effb64075b9888cc220ffeee477d9d67a9c3c.tar.gz
gentoo-ee3effb64075b9888cc220ffeee477d9d67a9c3c.tar.bz2
gentoo-ee3effb64075b9888cc220ffeee477d9d67a9c3c.zip
dev-python/cherrypy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/Manifest2
-rw-r--r--dev-python/cherrypy/cherrypy-18.5.0.ebuild63
-rw-r--r--dev-python/cherrypy/cherrypy-3.8.0.ebuild51
3 files changed, 0 insertions, 116 deletions
diff --git a/dev-python/cherrypy/Manifest b/dev-python/cherrypy/Manifest
index 73e1621e0850..6414d1c7d60a 100644
--- a/dev-python/cherrypy/Manifest
+++ b/dev-python/cherrypy/Manifest
@@ -1,3 +1 @@
-DIST CherryPy-18.5.0.tar.gz 685362 BLAKE2B 36178ff6e374a89aa4fba9ba34947f1558a7bb3676f014528bb081efa9608ed70648bf2c46b8c4f95b8b14586a93c513ce342955677564f9202733104ba07102 SHA512 6ead115ac2a067cc9f2cb83117b8c53aac8a2a1580159993b7687b5810a41b64d1d1c603ef75a12660fe7aee9c6f403c8cb7bd5e78564f71dc813ae7f28b65fe
DIST CherryPy-18.6.0.tar.gz 686804 BLAKE2B dae7f0ac403084acdf611e4a9e75f152355491e4383a1bd1374ae77ac68b415f41ce79f1e65a7a66c61aa0965ac94cd9bfd0d425cf7752ab54edf0bc0d8cabfb SHA512 cd33303fa9b9704ef427553091a6a6c2bbfea20e7d81acd2bcdc2855f8a36a084a0781bb19f3a084b24f0664bd7b318a667c8c79b5073381901acce4602de9d7
-DIST CherryPy-3.8.0.tar.gz 433711 BLAKE2B e1b4a554138a61e8c6313c3055723583d812e573a352d67bd5448f799e4f2f22694b800810b53cd041c665e46d9555b471d1da91c252ade96459778d7a5c07fa SHA512 25f84093e30d814c0980f7d77b98492113470c3297c66ee8652e40650757f8e2b7db01bb8de6d7a1ea9b4bed8b764502b1f563ac6f0d082970bc2d46739d19c2
diff --git a/dev-python/cherrypy/cherrypy-18.5.0.ebuild b/dev-python/cherrypy/cherrypy-18.5.0.ebuild
deleted file mode 100644
index 20a069c7dfd3..000000000000
--- a/dev-python/cherrypy/cherrypy-18.5.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ia64 ppc ~ppc64 x86"
-IUSE="ssl test"
-
-RDEPEND=">=dev-python/cheroot-8.2.1[${PYTHON_USEDEP}]
- >=dev-python/portend-2.1.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/zc-lockfile[${PYTHON_USEDEP}]
- dev-python/jaraco-collections[${PYTHON_USEDEP}]
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/routes[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/objgraph[${PYTHON_USEDEP}]
- dev-python/path-py[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
- dev-python/pytest-services[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # UnicodeEncodeError: 'ascii' codec can't encode character u'\u2603' in position 0: ordinal not in range(128)
- sed -e 's|@pytest.mark.xfail(py27_on_windows|@pytest.mark.xfail(sys.version_info < (3,)|' \
- -i cherrypy/test/test_static.py || die
-
- # fragile, fails with newer versions of CPython
- sed -e 's:testCombinedTools:_&:' \
- -i cherrypy/test/test_tools.py || die
-
- sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
- -i setup.py || die
-
- sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::g' \
- -e 's:--cov[[:graph:]]+::g' \
- -e 's:--doctest[[:graph:]]+::g' \
- -i pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/cherrypy/cherrypy-3.8.0.ebuild b/dev-python/cherrypy/cherrypy-3.8.0.ebuild
deleted file mode 100644
index 94e2448613ca..000000000000
--- a/dev-python/cherrypy/cherrypy-3.8.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_P="CherryPy-${PV}"
-
-DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
-HOMEPAGE="https://www.cherrypy.org https://pypi.org/project/CherryPy/"
-SRC_URI="mirror://pypi/C/CherryPy/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/nose-1.3.3[${PYTHON_USEDEP}] )"
-RDEPEND=""
-S="${WORKDIR}/${MY_P}"
-
-# testsuite predominantly connects to the network
-RESTRICT="test"
-
-python_prepare_all() {
- # Prevent interactive failures (hangs) in the test suite
- sed -i -e "s/interactive = True/interactive = False/" cherrypy/test/webtest.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # suite requires current latest nose-1.3.3
- # https://bitbucket.org/cherrypy/cherrypy/issue/1308
- # https://bitbucket.org/cherrypy/cherrypy/issue/1306
- local exclude=(
- -e test_file_stream -e test_4_File_deletion -e test_3_Redirect
- -e test_2_File_Concurrency -e test_0_Session -e testStatic
- )
-
- # This really doesn't sit well with multiprocessing
- # The issue 1306 tells us some tests are subject to the deleterious effects of
- # the 'race condition'. Both the issues are unresolved / open
-# if [[ "${EPYTHON}" == pypy ]]; then
- nosetests "${exclude[@]}" -I test_logging.py || die "Testing failed with ${EPYTHON}"
-# else
-# nosetests "${exclude[@]}" < /dev/tty || die "Testing failed with ${EPYTHON}"
-# fi
-}