summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-01 18:41:38 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-01 22:53:20 +0200
commit2fc71e0ca13ae8c71d986e86d3e9836de5f78d06 (patch)
tree61ef3520aed1c8df53b248550062cb3533ca74b8 /dev-python/clang-python
parentsys-devel/clang: 9999 is now 8.0 (diff)
downloadgentoo-2fc71e0ca13ae8c71d986e86d3e9836de5f78d06.tar.gz
gentoo-2fc71e0ca13ae8c71d986e86d3e9836de5f78d06.tar.bz2
gentoo-2fc71e0ca13ae8c71d986e86d3e9836de5f78d06.zip
dev-python/clang-python: Branch out LLVM 7.0
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/clang-python-7.0.9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-7.0.9999.ebuild b/dev-python/clang-python/clang-python-7.0.9999.ebuild
new file mode 100644
index 000000000000..d0d8cf54084d
--- /dev/null
+++ b/dev-python/clang-python/clang-python-7.0.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_70"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' bindings/python
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}