summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-06 12:04:19 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-06 12:06:13 +0100
commit39c9a71f9d7afdf2993b9fca32eaa9171fba29c9 (patch)
tree364ac4368f3f77edec6adb133cc1b5b72e69b770 /dev-python/clang-python
parentsys-devel/clang: Bump to 7.0.1_rc2 (diff)
downloadgentoo-39c9a71f9d7afdf2993b9fca32eaa9171fba29c9.tar.gz
gentoo-39c9a71f9d7afdf2993b9fca32eaa9171fba29c9.tar.bz2
gentoo-39c9a71f9d7afdf2993b9fca32eaa9171fba29c9.zip
dev-python/clang-python: Bump to 7.0.1_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-7.0.1_rc2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 80e31879e3f4..af23fec60040 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -2,3 +2,4 @@ DIST cfe-4.0.1.src.tar.xz 10933628 BLAKE2B bc1bb8875e83ccecd446a48cfa41f5c98a09d
DIST cfe-5.0.2.src.tar.xz 11459216 BLAKE2B 80d9b2ab70b00c0dfd5c5386a44e0c15d8252e6175c9da55a0519c4f9b8192e32e215110d7d3808225786e2c7f906f2dfbe11dd09bdf21574e99709ae237ed0b SHA512 9931afceb5569ad6caec85d506180c810f7fea94af8c997143b0a37cbf413fcea0d92520478610627eeee1efb65fde684066ace0dfcbbf7b61ecd709d22dd0b1
DIST cfe-6.0.1.src.tar.xz 11905772 BLAKE2B abb60e9f9827d1d8a24f0aaf8a1d1e32979293cc401258d230f93290e633645747fd0344af189ac7081b06be2cada503364e1e432b37110ade4b3578e40c7605 SHA512 f64ba9290059f6e36fee41c8f32bf483609d31c291fcd2f77d41fecfdf3c8233a5e23b93a1c73fed03683823bd6e72757ed993dd32527de3d5f2b7a64bb031b9
DIST cfe-7.0.0.src.tar.xz 12541904 BLAKE2B 92ecfcb37e7efb4f3dde275e7a087a52f1ddc607bee78fd222f87e6391ab7deb9a4e761c05e405126f46170fdff04aeaf9bd1e886a326c92a064ca81be4e6f21 SHA512 17a658032a0160c57d4dc23cb45a1516a897e0e2ba4ebff29472e471feca04c5b68cff351cdf231b42aab0cff587b84fe11b921d1ca7194a90e6485913d62cb7
+DIST cfe-7.0.1rc2.src.tar.xz 12487728 BLAKE2B bba0f7751106ac0438b5db9cbd0e0c5d2f3fe35255eb49cf4ed6a8efbc7e8be3f8263f0d663a739409232e591ab74e7b0abaf4cc1df0d7605db913eac0a085ba SHA512 2e178f1829edd6a7a0f0919358adfe0a88fc8a83b629bf64411cb33181df43b48bf47057b6c3bba95ab939998f7a8db05717bc1e58f175c8dae5df881c88d48f
diff --git a/dev-python/clang-python/clang-python-7.0.1_rc2.ebuild b/dev-python/clang-python/clang-python-7.0.1_rc2.ebuild
new file mode 100644
index 000000000000..0f0cb8be6c8a
--- /dev/null
+++ b/dev-python/clang-python/clang-python-7.0.1_rc2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit python-r1
+
+MY_P=cfe-${PV/_/}.src
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://prereleases.llvm.org/${PV/_//}/${MY_P}.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-fbsd"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}/bindings/python
+
+PATCHES=(
+ # update completion test results due to completion changes
+ # https://reviews.llvm.org/D50171
+ "${FILESDIR}"/7.0.0/0001-python-tests-Update-test_code_completion.patch
+)
+
+src_unpack() {
+ einfo "Unpacking parts of ${MY_P}.tar.xz ..."
+ tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}