summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 07:40:12 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 08:02:56 +0200
commitfe938ae54cccf52fa15655e43b276f2fe9962364 (patch)
tree99957e08ed6a0cf5e875ff85df8cfdf935144e77 /dev-python/cli_helpers/cli_helpers-2.1.0.ebuild
parentdev-python/terminaltables: Port to py3.9, fix tests (diff)
downloadgentoo-fe938ae54cccf52fa15655e43b276f2fe9962364.tar.gz
gentoo-fe938ae54cccf52fa15655e43b276f2fe9962364.tar.bz2
gentoo-fe938ae54cccf52fa15655e43b276f2fe9962364.zip
dev-python/cli_helpers: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-2.1.0.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild
new file mode 100644
index 000000000000..b4159629ae3a
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest