summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-05-30 12:05:10 +0200
committerSlawomir Lis <slis@gentoo.org>2017-05-30 12:34:51 +0200
commit397569b9fe339c8fad74141fb769d3bed6fe1a19 (patch)
tree1bd57b6ffca47eb84ee4a753764d1d1909957e4c /dev-python/click-plugins/click-plugins-1.0.3.ebuild
parentdev-python/munch: fixed licence (diff)
downloadgentoo-397569b9fe339c8fad74141fb769d3bed6fe1a19.tar.gz
gentoo-397569b9fe339c8fad74141fb769d3bed6fe1a19.tar.bz2
gentoo-397569b9fe339c8fad74141fb769d3bed6fe1a19.zip
dev-python/click-plugins: added package
Needed by sci-libs/Fiona Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/click-plugins/click-plugins-1.0.3.ebuild')
-rw-r--r--dev-python/click-plugins/click-plugins-1.0.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/click-plugins/click-plugins-1.0.3.ebuild b/dev-python/click-plugins/click-plugins-1.0.3.ebuild
new file mode 100644
index 000000000000..8eb1422d3a1c
--- /dev/null
+++ b/dev-python/click-plugins/click-plugins-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for click to enable registering CLI commands via setuptools entry-points"
+HOMEPAGE="https://pypi.python.org/pypi/click-plugins"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"