summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-08-07 13:07:31 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-07 13:08:19 -0400
commit8f8d296ff61b0e88bf6f243474790e498bf26123 (patch)
tree3925f70f9eff965deda88a9e6a9ed8cb600d79ec /dev-python/cliff-tablib
parentmedia-gfx/openvdb: restrict tests (diff)
downloadgentoo-8f8d296ff61b0e88bf6f243474790e498bf26123.tar.gz
gentoo-8f8d296ff61b0e88bf6f243474790e498bf26123.tar.bz2
gentoo-8f8d296ff61b0e88bf6f243474790e498bf26123.zip
dev-python/cliff-tablib: drop py34 support
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/cliff-tablib')
-rw-r--r--dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild b/dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild
new file mode 100644
index 000000000000..c2af04685f61
--- /dev/null
+++ b/dev-python/cliff-tablib/cliff-tablib-1.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Formatter extensions of JSON, YAML, and HTML output for the cliff framework"
+HOMEPAGE="https://github.com/dreamhost/cliff-tablib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="dev-python/tablib[${PYTHON_USEDEP}]
+ dev-python/cliff[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ # Use IUSE examples for installing the demoapp
+ use examples && local EXAMPLES=( demoapp/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}