summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-19 00:36:17 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-19 00:47:40 +0100
commita51ca11528d1638e28fec22c7469e3fc4ed8ce77 (patch)
tree3b3020fcbee7fde81f93ee3a866406ffb3c60be5 /dev-python/cliff
parentxfce-extra/xfce4-notes-plugin: Bump to 1.9.0 (diff)
downloadgentoo-a51ca11528d1638e28fec22c7469e3fc4ed8ce77.tar.gz
gentoo-a51ca11528d1638e28fec22c7469e3fc4ed8ce77.tar.bz2
gentoo-a51ca11528d1638e28fec22c7469e3fc4ed8ce77.zip
dev-python/cliff: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.6.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index 1804ae8328b6..6d583447ca67 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-3.5.0.tar.gz 82997 BLAKE2B f169770a0a956e6091e56eccda8d10906bee09bdb03b474f3b17837b3eda858f3afd21beae1d6945bcdabfa89fc1555d13d70ddd0454a10fe05bfb63c8de75e7 SHA512 215f22e5dd2c4c17bd0f19866189b6b247377a7d5bddeb4a07b7536af7545bd0440b5fb0a98474fc018e3b12f6695f60028c012f3e7eeb6498b20f2923939d08
+DIST cliff-3.6.0.tar.gz 80464 BLAKE2B 2b7efb07123fd9939c5717d6bdc1685d2e6474f3852e920c8d93f8a3e7ba20e433dbead97040ab035c4081058b621740ff64045c282a0568393fe8453da245d9 SHA512 ed4077e8b9e848dbd8aebb076b9f55086ea861cbf22322f7c9fb03a66b88bd60f5c09c6914481fe5f02bad25c0183e245405d9ac54d37b6bf0f14c9c97bd7684
diff --git a/dev-python/cliff/cliff-3.6.0.ebuild b/dev-python/cliff/cliff-3.6.0.ebuild
new file mode 100644
index 000000000000..a3bff2da3f73
--- /dev/null
+++ b/dev-python/cliff/cliff-3.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest