summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/clint
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/Manifest3
-rw-r--r--dev-python/clint/clint-0.3.1-r1.ebuild41
-rw-r--r--dev-python/clint/clint-0.3.7.ebuild38
-rw-r--r--dev-python/clint/clint-0.4.1.ebuild38
-rw-r--r--dev-python/clint/files/clint-setup.patch15
-rw-r--r--dev-python/clint/metadata.xml13
6 files changed, 148 insertions, 0 deletions
diff --git a/dev-python/clint/Manifest b/dev-python/clint/Manifest
new file mode 100644
index 000000000000..c660d258b338
--- /dev/null
+++ b/dev-python/clint/Manifest
@@ -0,0 +1,3 @@
+DIST clint-0.3.1.tar.gz 147154 SHA256 faa94e073e1c8d26e67b34ef1d69d6cd92bd06e87a94cc451d587b4c8b965e1e SHA512 c7a1ccca82d1530e9501f2f854a90f4840cdb4bc2536c8eca30832f156c0898d02d9b839be6b9bf0425b1fa0f94940ef223c55cfd50c183c89b3822ca90b4aba WHIRLPOOL 2da1e651c8b9f038261de3c8908cbbc737debea6475c9268d1b1c48bef8bfe5795ba6b931bbc614431e7798823db6e1ab1e7aead3db91141a3b9752076f24b0c
+DIST clint-0.3.7.tar.gz 149553 SHA256 efef49442bc18de26aea4f76aeef09f9ffc90d4d99f06109e6dd2390ae58d98c SHA512 7d0becec7d412077f0fff7b2bfb278b835cfa271c89ed5fe8cce5116c1be6ae393a3e7146691c55470c57b29d82e9895e41ac292801e3720fe2b1797a67438d0 WHIRLPOOL f4bdf5e5892359db24550ac052396e585753ad62fd99feb245bf2a63153e3c8b70e095532a54ca11fc8134a3517e48e1fd7eaea4edb1005c7ace6f2ee253da6a
+DIST clint-0.4.1.tar.gz 80383 SHA256 6709b638fd13fc2395284d0d42fe857ce97fdb6f03929ceb7ece28393933b4ea SHA512 8ee4fb8d7e5416c0c1c6c23abddb255521a7d682cb855a9fe2446137e83f739a1c44c135a05803632b896fa39400c33f44e5a78442af21bebd3cf66d28fbc9fc WHIRLPOOL 0dd5c062d025bc6ebfd304b056f75294eaac5868afec2c0c2403f380c6e2043478280b2c5ce575060af3939cdcae71d4ebc62b40edb011216535b115ef29c379
diff --git a/dev-python/clint/clint-0.3.1-r1.ebuild b/dev-python/clint/clint-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..699af441d963
--- /dev/null
+++ b/dev-python/clint/clint-0.3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+# Prevent install of files to wrong location
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/clint-0.3.7.ebuild b/dev-python/clint/clint-0.3.7.ebuild
new file mode 100644
index 000000000000..7530fa6a956d
--- /dev/null
+++ b/dev-python/clint/clint-0.3.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/clint-0.4.1.ebuild b/dev-python/clint/clint-0.4.1.ebuild
new file mode 100644
index 000000000000..cca7df08a9b0
--- /dev/null
+++ b/dev-python/clint/clint-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/clint/files/clint-setup.patch b/dev-python/clint/files/clint-setup.patch
new file mode 100644
index 000000000000..960dc99be429
--- /dev/null
+++ b/dev-python/clint/files/clint-setup.patch
@@ -0,0 +1,15 @@
+setup.py installs data files to /usr/ !!!??!!
+diff -ur clint-0.3.1.orig/setup.py clint-0.3.1/setup.py
+--- setup.py 2012-01-16 22:25:54.000000000 +0800
++++ setup.py 2014-10-11 12:20:29.174133572 +0800
+@@ -29,10 +29,6 @@
+ author='Kenneth Reitz',
+ author_email='me@kennethreitz.com',
+ url='https://github.com/kennethreitz/clint',
+- data_files=[
+- 'README.rst',
+- 'HISTORY.rst',
+- ],
+ packages= [
+ 'clint',
+ 'clint.textui',
diff --git a/dev-python/clint/metadata.xml b/dev-python/clint/metadata.xml
new file mode 100644
index 000000000000..61f985dbe7fb
--- /dev/null
+++ b/dev-python/clint/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kennethreitz/clint</remote-id>
+ </upstream>
+</pkgmetadata>