summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-08-29 18:25:52 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-08-29 18:34:27 -0500
commitc80d82c3db117c867d2a21178a56ab74402abf39 (patch)
treef9d7a477f648bbc899292d88b762ecb23ce08b75 /dev-python/clint
parentx11-drivers/xf86-video-voodoo: Add patch to fix compilation. (diff)
downloadgentoo-c80d82c3db117c867d2a21178a56ab74402abf39.tar.gz
gentoo-c80d82c3db117c867d2a21178a56ab74402abf39.tar.bz2
gentoo-c80d82c3db117c867d2a21178a56ab74402abf39.zip
dev-python/clint: add version 0.5.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/clint')
-rw-r--r--dev-python/clint/Manifest1
-rw-r--r--dev-python/clint/clint-0.5.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/clint/Manifest b/dev-python/clint/Manifest
index c660d258b338..d1c99ab0ca2c 100644
--- a/dev-python/clint/Manifest
+++ b/dev-python/clint/Manifest
@@ -1,3 +1,4 @@
DIST clint-0.3.1.tar.gz 147154 SHA256 faa94e073e1c8d26e67b34ef1d69d6cd92bd06e87a94cc451d587b4c8b965e1e SHA512 c7a1ccca82d1530e9501f2f854a90f4840cdb4bc2536c8eca30832f156c0898d02d9b839be6b9bf0425b1fa0f94940ef223c55cfd50c183c89b3822ca90b4aba WHIRLPOOL 2da1e651c8b9f038261de3c8908cbbc737debea6475c9268d1b1c48bef8bfe5795ba6b931bbc614431e7798823db6e1ab1e7aead3db91141a3b9752076f24b0c
DIST clint-0.3.7.tar.gz 149553 SHA256 efef49442bc18de26aea4f76aeef09f9ffc90d4d99f06109e6dd2390ae58d98c SHA512 7d0becec7d412077f0fff7b2bfb278b835cfa271c89ed5fe8cce5116c1be6ae393a3e7146691c55470c57b29d82e9895e41ac292801e3720fe2b1797a67438d0 WHIRLPOOL f4bdf5e5892359db24550ac052396e585753ad62fd99feb245bf2a63153e3c8b70e095532a54ca11fc8134a3517e48e1fd7eaea4edb1005c7ace6f2ee253da6a
DIST clint-0.4.1.tar.gz 80383 SHA256 6709b638fd13fc2395284d0d42fe857ce97fdb6f03929ceb7ece28393933b4ea SHA512 8ee4fb8d7e5416c0c1c6c23abddb255521a7d682cb855a9fe2446137e83f739a1c44c135a05803632b896fa39400c33f44e5a78442af21bebd3cf66d28fbc9fc WHIRLPOOL 0dd5c062d025bc6ebfd304b056f75294eaac5868afec2c0c2403f380c6e2043478280b2c5ce575060af3939cdcae71d4ebc62b40edb011216535b115ef29c379
+DIST clint-0.5.1.tar.gz 81140 SHA256 cc2ac47fca097d6235fd12e70a4984a63c4ea1992eb0cee04fe8ed13c88544cd SHA512 3ad8bfc587acb1322c7d7c3e73756a07c98f3b4215a3d4dc409b5a2067bc70dce2dd98d19250b8122b319b7bcf5e2859251de2829780345de06f93b35447c4e8 WHIRLPOOL 46d92ae120ffc6b36237d13e3b8036f7d0a8d8f5b79ae9a0f9a3cbfa7c6f4853a5d4227efaa74d451525fd07df9cc3992c7d99309e08af44ff173b174105d0e7
diff --git a/dev-python/clint/clint-0.5.1.ebuild b/dev-python/clint/clint-0.5.1.ebuild
new file mode 100644
index 000000000000..68adb167258a
--- /dev/null
+++ b/dev-python/clint/clint-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}