summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/codetools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/codetools')
-rw-r--r--dev-python/codetools/Manifest1
-rw-r--r--dev-python/codetools/codetools-4.2.0.ebuild36
-rw-r--r--dev-python/codetools/metadata.xml22
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/codetools/Manifest b/dev-python/codetools/Manifest
new file mode 100644
index 000000000000..392308f9aa84
--- /dev/null
+++ b/dev-python/codetools/Manifest
@@ -0,0 +1 @@
+DIST codetools-4.2.0.tar.gz 117891 SHA256 a93452b3f421bb5f9f18a74d404661433e189e29de3a4b9cfe92544e69be9c2c SHA512 8b63b9cb65966db72f3d2b054559fadf3008a4f4a7fc66ff12b046ca18568694c9d11066d6450e38b053b73df31c8a136729d7052bf8e21f287eac220ddf5dbb WHIRLPOOL adf4f8f3a516cf14cb8c71a4874b80c09814b017872be5dbb7768e506fecfc76d59805763d1cf3dbfdf941f86efd3893545e314932bad93c461a4468cee5c15e
diff --git a/dev-python/codetools/codetools-4.2.0.ebuild b/dev-python/codetools/codetools-4.2.0.ebuild
new file mode 100644
index 000000000000..648a3fc100e1
--- /dev/null
+++ b/dev-python/codetools/codetools-4.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Code analysis and execution tools"
+HOMEPAGE="http://code.enthought.com/projects/code_tools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+IUSE="test"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/scimath-4[${PYTHON_USEDEP}]
+ >=dev-python/traits-4[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/blockcanvas[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ virtual/python-futures[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake -e with_mask_test_case
+}
diff --git a/dev-python/codetools/metadata.xml b/dev-python/codetools/metadata.xml
new file mode 100644
index 000000000000..6f5804ff43a6
--- /dev/null
+++ b/dev-python/codetools/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ The CodeTools project from the Enthought Tool Suite
+ includes packages that simplify meta-programming
+ and help the programmer separate data from code in Python. This
+ library contains classes that allow defining simple snippets, or
+ "blocks", of Python code, analyze variable dependencies in the code
+ block, and use these dependencies to construct or restrict an
+ execution graph. These (restricted) code blocks can then be executed
+ in any namespace. However, this project also provides a
+ Traits-event-enhanced namespace, called a "context", which can be used
+ in place of a vanilla namespace to allow actions to be performed
+ whenever variables are assigned or retrieved from the namespace. This
+ project is used as the foundation for the BlockCanvas project.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">codetools</remote-id>
+</upstream>
+</pkgmetadata>