summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-24 09:37:08 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-24 09:37:08 +0100
commit6992c69f0ee9b45d583c696a51f0abd4cbd11da1 (patch)
tree9a04fa2a292d4114320344a59858f97e236c438d /dev-python/colorama/colorama-0.3.6-r1.ebuild
parentsys-libs/ldb: Removed old. (diff)
downloadgentoo-6992c69f0ee9b45d583c696a51f0abd4cbd11da1.tar.gz
gentoo-6992c69f0ee9b45d583c696a51f0abd4cbd11da1.tar.bz2
gentoo-6992c69f0ee9b45d583c696a51f0abd4cbd11da1.zip
dev-python/colorama: Revbump because of EAPI bump and patch addition
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/colorama/colorama-0.3.6-r1.ebuild')
-rw-r--r--dev-python/colorama/colorama-0.3.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/colorama/colorama-0.3.6-r1.ebuild b/dev-python/colorama/colorama-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..7cc88846d36b
--- /dev/null
+++ b/dev-python/colorama/colorama-0.3.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.python.org/pypi/colorama
+ https://github.com/tartley/colorama"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+python_install_all() {
+ use examples && local EXAMPLES=( demos/. )
+ distutils-r1_python_install_all
+}