summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 18:49:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 19:54:35 +0200
commit0604c9a10a3bf768a700110ba8b2193b1354e159 (patch)
tree7e54bad4a2a771265f07ba560cd11d6a3fe0458d /dev-python/colorama
parentdev-python/click: Enable py3.11 (diff)
downloadgentoo-0604c9a10a3bf768a700110ba8b2193b1354e159.tar.gz
gentoo-0604c9a10a3bf768a700110ba8b2193b1354e159.tar.bz2
gentoo-0604c9a10a3bf768a700110ba8b2193b1354e159.zip
dev-python/colorama: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/colorama')
-rw-r--r--dev-python/colorama/colorama-0.4.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/colorama/colorama-0.4.4-r1.ebuild b/dev-python/colorama/colorama-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..081e4bc98702
--- /dev/null
+++ b/dev-python/colorama/colorama-0.4.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI escape character sequences for colored terminal text & cursor positioning"
+HOMEPAGE="
+ https://pypi.org/project/colorama/
+ https://github.com/tartley/colorama/
+"
+# https://github.com/tartley/colorama/pull/183
+SRC_URI="https://github.com/tartley/${PN}/archive/${PV}.tar.gz -> ${P}.github.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Some tests require stdout to be a TTY
+ # https://github.com/tartley/colorama/issues/169
+ script -eqc "${EPYTHON} -m pytest -vv -s" /dev/null \
+ || die "tests failed with ${EPYTHON}"
+}