summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-15 09:15:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-15 09:34:12 +0100
commit0fd963399b93b0340015ed5fa0b11bf2fd92f42e (patch)
tree065dcb52729a35e8846d34c524fa27900a3ab061 /dev-python/configargparse
parentdev-python/sphinx: Bump to 3.5.0 (diff)
downloadgentoo-0fd963399b93b0340015ed5fa0b11bf2fd92f42e.tar.gz
gentoo-0fd963399b93b0340015ed5fa0b11bf2fd92f42e.tar.bz2
gentoo-0fd963399b93b0340015ed5fa0b11bf2fd92f42e.zip
dev-python/configargparse: Bump to 1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configargparse')
-rw-r--r--dev-python/configargparse/Manifest1
-rw-r--r--dev-python/configargparse/configargparse-1.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/configargparse/Manifest b/dev-python/configargparse/Manifest
index 8f8bcacf7c14..ce89b4d890c1 100644
--- a/dev-python/configargparse/Manifest
+++ b/dev-python/configargparse/Manifest
@@ -1 +1,2 @@
DIST ConfigArgParse-1.2.3.gh.tar.gz 27858 BLAKE2B f8dbb1dfc9312107abcd0c715b93736cdb86a7742270932d13b768ac7a13f805902f026d5cb34e196a8c5c659af65c13698c2cc301b522b99bb0c019b2c0e68d SHA512 bfa8f9ca8ab5c6d4cdf2a7e7c577c99fafdf7f743c81057bebbb6045c45de2cdbf5d738f7765e5dcac5a45baa92e2a8bc7ad3879776b9cf4862e3da94e78c4cc
+DIST ConfigArgParse-1.3.gh.tar.gz 28274 BLAKE2B 0ea46747425d978da0de35e7ac29c91ee637f1c793265eeecf702ec504b1d1083d31bdaa48134de2916733f845cd68690af2ff0765b3a5bdc98365d03aad4492 SHA512 7f7048babacaada3495ece42d6bd484b07d648c2b2c1a8e700379aae6c65d96c37bf15a20f90281e2c0d83948e22986689c4b02e0388d9bf01e77d9d1561b0c5
diff --git a/dev-python/configargparse/configargparse-1.3.ebuild b/dev-python/configargparse/configargparse-1.3.ebuild
new file mode 100644
index 000000000000..1c8ac6ffd0a9
--- /dev/null
+++ b/dev-python/configargparse/configargparse-1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="ConfigArgParse"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="https://github.com/bw2/ConfigArgParse https://pypi.org/project/ConfigArgParse/"
+SRC_URI="https://github.com/bw2/ConfigArgParse/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ local -x COLUMNS=80
+ esetup.py test
+}