summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-22 15:19:28 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-22 15:22:22 +0100
commitbba9c1ff011773be5b13ce2340d2c5ca32beb39c (patch)
tree145ee25332fe06231b219c2cc4023477194fb519 /dev-python/constantly/constantly-15.1.0-r1.ebuild
parentdev-util/cmocka: Tested on ~amd64-fbsd (diff)
downloadgentoo-bba9c1ff011773be5b13ce2340d2c5ca32beb39c.tar.gz
gentoo-bba9c1ff011773be5b13ce2340d2c5ca32beb39c.tar.bz2
gentoo-bba9c1ff011773be5b13ce2340d2c5ca32beb39c.zip
dev-python/constantly: Enable tests
Diffstat (limited to 'dev-python/constantly/constantly-15.1.0-r1.ebuild')
-rw-r--r--dev-python/constantly/constantly-15.1.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/constantly/constantly-15.1.0-r1.ebuild b/dev-python/constantly/constantly-15.1.0-r1.ebuild
new file mode 100644
index 000000000000..baef122ff147
--- /dev/null
+++ b/dev-python/constantly/constantly-15.1.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Symbolic constants in Python"
+HOMEPAGE="https://github.com/twisted/constantly https://pypi.python.org/pypi/constantly"
+SRC_URI="https://github.com/twisted/constantly/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}