summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 16:59:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-27 22:45:08 +0200
commit58325a1cdeb0de9ffe9b87a1b6edcea422c9ebff (patch)
treeff1222e4c127265b06a017179a9747b26be86834 /dev-python/coverage
parentdev-python/pytest-localserver: Port to py39 (diff)
downloadgentoo-58325a1cdeb0de9ffe9b87a1b6edcea422c9ebff.tar.gz
gentoo-58325a1cdeb0de9ffe9b87a1b6edcea422c9ebff.tar.bz2
gentoo-58325a1cdeb0de9ffe9b87a1b6edcea422c9ebff.zip
dev-python/coverage: Bump to 5.1, py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/coverage')
-rw-r--r--dev-python/coverage/Manifest1
-rw-r--r--dev-python/coverage/coverage-5.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/coverage/Manifest b/dev-python/coverage/Manifest
index 23bb7b0dffe9..38894af7959a 100644
--- a/dev-python/coverage/Manifest
+++ b/dev-python/coverage/Manifest
@@ -1,3 +1,4 @@
DIST coverage-4.5.2.tar.gz 384845 BLAKE2B a7b4f249a68e025449d26ef8ee2194b9ce355c979d1f5192a7863a0ab0089f9deb3a8e63a39bef528ed7c58fbcc7cd4bc193fea3a135f5996a6655268a6b7a93 SHA512 0d98c8118648a319ac6f3b4c4c6f1ff8a92085bbe8276dd5504c8df4638933f920d7382d8e6de8e16bff43b62091310e0eab7b7722c6d28c976baedbfae3d03e
DIST coverage-4.5.4.tar.gz 385185 BLAKE2B 9d040bff13cebd1cb7147f15c3ec03bb08648cf801b5b2bb046a6b5bcadb3d3886be8bf0a624d225f25d10a5ca82fe5fb88f55e44e92a0a3285836b837972970 SHA512 ba534e04fe35cbadc4b16735f25c08f579a49a6677ec106680f222f2dfb3d0f1e011d0962f1c2108c375173ac4588bea1619ecda05ff9ba6fd888daddfd27b0e
DIST coverage-5.0.3.tar.gz 679171 BLAKE2B b87b256ecdae0b63ae08ed1aea9ff1f4177ec5da63c18615d66f207c3b7c71da4730432bfbdb66a8b55fa2056016226b09befdfc5d0fae57ccc56f08b2690b38 SHA512 51c648b4529cc84534865ee804bcd3dd35a6dcb23f20feb3c4702025b924de3a010fd8d08238eea926ae1874c5510ff006bc120e10d01db795ea0af6fb82834c
+DIST coverage-5.1.tar.gz 687427 BLAKE2B f4eee548cd6fb58c4a527b9e0ac5ee4133c984358f42ca0c87301f95eb60253a2748ccf9d4e88358941d7897998e68e3c5e70e6dc7387bf5e60eda950f4a679c SHA512 7bd3ca158fe2eab1946c52161fb877623d4ed0382de193aa6eb267443fdda86089ec7aaae518115d6a3b5487fd1400320eb503b9afe83182fb3c3621ccbfb6d7
diff --git a/dev-python/coverage/coverage-5.1.ebuild b/dev-python/coverage/coverage-5.1.ebuild
new file mode 100644
index 000000000000..b0e701db5f01
--- /dev/null
+++ b/dev-python/coverage/coverage-5.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Code coverage measurement for Python"
+HOMEPAGE="https://coverage.readthedocs.io/en/latest/ https://pypi.org/project/coverage/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc"
+#IUSE="test"
+# The tests are impossible to appease. Please run them externally
+# via tox. Or fix the ebuild if you have hours of time to spend
+# on something utterly useless.
+RESTRICT="test"
+
+#BDEPEND="
+# test? (
+# dev-python/PyContracts[${PYTHON_USEDEP}]
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# >=dev-python/unittest-mixins-1.4[${PYTHON_USEDEP}]
+# )
+#"
+
+src_prepare() {
+ # avoid the dep on xdist, run tests verbosely
+ sed -i -e '/^addopts/s:-n3:-v:' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == python2.7 ]]; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ distutils_install_for_testing
+ local bindir=${TEST_DIR}/scripts
+
+ pushd tests/eggsrc >/dev/null || die
+ distutils_install_for_testing
+ popd >/dev/null || die
+
+ "${EPYTHON}" igor.py zip_mods || die
+ PATH="${bindir}:${PATH}" "${EPYTHON}" igor.py test_with_tracer py || die
+
+ # No C extensions under pypy
+ if [[ ${EPYTHON} != pypy* ]]; then
+ cp -l -- "${TEST_DIR}"/lib/*/coverage/*.so coverage/ || die
+ PATH="${bindir}:${PATH}" "${EPYTHON}" igor.py test_with_tracer c || die
+ fi
+
+ # clean up leftover "egg1" directory
+ rm -rf build/lib/egg1 || die
+}